PraisonAI: Python Sandbox Escape via str Subclass startswith() Override in execute_code
CVE-2026-34938GHSA-6vh2-h83c-9294
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.5.90), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonaiagents
- Affected
- <= 1.5.89
- Fixed in
- 1.5.90
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6vh2-h83c-9294 lists affected ranges: PyPI praisonaiagents >=0 <=1.5.89
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6vh2-h83c-9294 lists affected ranges: PyPI praisonaiagents >=0 <1.5.90 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-34938: 13.40% estimated exploitation activity in the next 30 days; percentile 96.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary executecode() in praisonai-agents runs attacker-controlled Python inside a three-layer sandbox that can be fully bypassed by passing a str subclass with an overridden startswith() method to the safegetattr wrapper, achieving arbitrary OS command execution on the host. Details pythontools.py:20 (source) - pythontools.py:22 (guard bypass) - pythontools.py:161 (sink) PoC Impact Any user or agent pipeline running executecode() is exposed to full OS command execution as the process user. Deployments using bot.py, autonomymode.py, or botscli.py set PRAISONAIAUTOAPPROVE=true by default, meaning no human confirmation is required and the tool fires silently when triggered via indirect prompt injection.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6vh2-h83c-9294
- Revision 2 · amended ·
Amended from osv record GHSA-6vh2-h83c-9294
- Revision 1 · created ·
Published from ghsa record GHSA-6vh2-h83c-9294
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34938 Advisory: PraisonAI: Python Sandbox Escape via str Subclass startswith() Override in execute_code IDs: CVE-2026-34938, GHSA-6vh2-h83c-9294 Record: https://patchnext.com/advisories/cve-2026-34938 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.5.90. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonaiagents: affected <= 1.5.89; fixed in 1.5.90 ## Suggested inspection (read-only) - `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonaiagents. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6vh2-h83c-9294 (GitHub-reviewed advisory GHSA-6vh2-h83c-9294 lists affected ranges: PyPI praisonaiagents >=0 <=1.5.89) - Verified: https://osv.dev/vulnerability/GHSA-6vh2-h83c-9294 (OSV record GHSA-6vh2-h83c-9294 lists affected ranges: PyPI praisonaiagents >=0 <1.5.90 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…