PraisonAI: SSRF via Unvalidated api_base in passthrough() Fallback
CVE-2026-34936GHSA-x6m9-gxvr-7jpv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.90), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai
- Affected
- <= 4.5.89
- Fixed in
- 4.5.90
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x6m9-gxvr-7jpv lists affected ranges: PyPI praisonai >=0 <4.5.90 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x6m9-gxvr-7jpv lists affected ranges: PyPI praisonai >=0 <=4.5.89
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-34936: 0.35% estimated exploitation activity in the next 30 days; percentile 28.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary passthrough() and apassthrough() in praisonai accept a caller-controlled apibase parameter that is concatenated with endpoint and passed directly to httpx.Client.request() when the litellm primary path raises AttributeError. No URL scheme validation, private IP filtering, or domain allowlist is applied, allowing requests to any host reachable from the server. Details passthrough.py:92 (source) - passthrough.py:109 (fallback trigger) - passthrough.py:110 (sink) PoC Impact On cloud infrastructure with IMDSv1 enabled, an attacker can retrieve IAM credentials via the EC2 metadata service. Internal services (Redis, Elasticsearch, Kubernetes API) are reachable without authentication from within the VPC. The Flask API server deploys with AUTHENABLED = False by default, making this reachable over the network without credentials.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x6m9-gxvr-7jpv
- Revision 1 · created ·
Published from osv record GHSA-x6m9-gxvr-7jpv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34936 Advisory: PraisonAI: SSRF via Unvalidated api_base in passthrough() Fallback IDs: CVE-2026-34936, GHSA-x6m9-gxvr-7jpv Record: https://patchnext.com/advisories/cve-2026-34936 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.90. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonai: affected <= 4.5.89; fixed in 4.5.90 ## Suggested inspection (read-only) - `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x6m9-gxvr-7jpv (OSV record GHSA-x6m9-gxvr-7jpv lists affected ranges: PyPI praisonai >=0 <4.5.90 (fixed)) - Verified: https://github.com/advisories/GHSA-x6m9-gxvr-7jpv (GitHub-reviewed advisory GHSA-x6m9-gxvr-7jpv lists affected ranges: PyPI praisonai >=0 <=4.5.89) Commands are suggestions: review each one before running it.
Loading voting…