Skip to content

← Actionable
Critical, CVSS 9.8amended

PraisonAI: OS Command Injection in MCPHandler.parse_mcp_command()

CVE-2026-34935GHSA-9gm9-c8mq-vq7m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.69), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    >= 4.5.15, <= 4.5.68
    Fixed in
    4.5.69

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-34935: 0.84% estimated exploitation activity in the next 30 days; percentile 57.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The --mcp CLI argument is passed directly to shlex.split() and forwarded through the call chain to anyio.openprocess() with no validation, allowlist check, or sanitization at any hop, allowing arbitrary OS command execution as the process user. Details cli/features/mcp.py:61 (source) - praisonaiagents/mcp/mcp.py:345 (hop) - mcp/client/stdio/init.py:253 (sink) Fixed in commit 47bff65413beaa3c21bf633c1fae4e684348368c (v4.5.69) by introducing a command allowlist: PoC Impact Any deployment where the --mcp argument is influenced by untrusted input is exposed to full OS command execution as the process user. No authentication is required.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9gm9-c8mq-vq7m

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9gm9-c8mq-vq7m

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9gm9-c8mq-vq7m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34935

Advisory: PraisonAI: OS Command Injection in MCPHandler.parse_mcp_command()
IDs: CVE-2026-34935, GHSA-9gm9-c8mq-vq7m
Record: https://patchnext.com/advisories/cve-2026-34935 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.69. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected >= 4.5.15, <= 4.5.68; fixed in 4.5.69

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9gm9-c8mq-vq7m (GitHub-reviewed advisory GHSA-9gm9-c8mq-vq7m lists affected ranges: PyPI praisonai >=4.5.15 <=4.5.68)
- Verified: https://osv.dev/vulnerability/GHSA-9gm9-c8mq-vq7m (OSV record GHSA-9gm9-c8mq-vq7m lists affected ranges: PyPI praisonai >=4.5.15 <4.5.69 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…