Rack's multipart header parsing allows Denial of Service via escape-heavy quoted parameters
CVE-2026-34827GHSA-v6x5-cg8r-vv6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.2.6, 3.1.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- >= 3.0.0.beta1, < 3.1.21>= 3.2.0, < 3.2.6
- Fixed in
- 3.1.21, 3.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v6x5-cg8r-vv6x lists affected ranges: RubyGems rack >=3.0.0.beta1 =3.2.0 <3.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-34827: 0.49% estimated exploitation activity in the next 30 days; percentile 42.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Rack::Multipart::Parser#handlemimehead parses quoted multipart parameters such as Content-Disposition: form-data; name="..." using repeated String#index searches combined with String#slice! prefix deletion. For escape-heavy quoted values, this causes super-linear processing. An unauthenticated attacker can send a crafted multipart/form-data request containing many parts with long backslash-escaped parameter values to trigger excessive CPU usage during multipart parsing. This results in a denial of service condition in Rack applications that accept multipart form data. Details Rack::Multipart::Parser#handlemimehead parses quoted parameter values by repeatedly: 1. Searching for the next quote or backslash, 2. Copying the preceding substring into a new buffer, and 3. Removing the processed prefix from the original string with slice!. An attacker can exploit this by sending a multipart request with many parts whose name parameters contain long escape-heavy values such as: Under…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v6x5-cg8r-vv6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34827 Advisory: Rack's multipart header parsing allows Denial of Service via escape-heavy quoted parameters IDs: CVE-2026-34827, GHSA-v6x5-cg8r-vv6x Record: https://patchnext.com/advisories/cve-2026-34827 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 3.2.6, 3.1.21. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected >= 3.0.0.beta1, < 3.1.21; >= 3.2.0, < 3.2.6; fixed in 3.1.21, 3.2.6 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v6x5-cg8r-vv6x (GitHub-reviewed advisory GHSA-v6x5-cg8r-vv6x lists affected ranges: RubyGems rack >=3.0.0.beta1 =3.2.0 <3.2.6) Commands are suggestions: review each one before running it.
Loading voting…