Rack's multipart byte range processing allows denial of service via excessive overlapping ranges
CVE-2026-34826GHSA-x8cg-fq8g-mxfx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.2.6, 3.1.21, 2.2.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- < 2.2.23>= 3.0.0.beta1, < 3.1.21>= 3.2.0, < 3.2.6
- Fixed in
- 3.1.21, 2.2.23, 3.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x8cg-fq8g-mxfx lists affected ranges: RubyGems rack >=0 =3.0.0.beta1 =3.2.0 <3.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-34826: 0.40% estimated exploitation activity in the next 30 days; percentile 33.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Rack::Utils.getbyteranges parses the HTTP Range header without limiting the number of individual byte ranges. Although the existing fix for CVE-2024-26141 rejects ranges whose total byte coverage exceeds the file size, it does not restrict the count of ranges. An attacker can supply many small overlapping ranges such as 0-0,0-0,0-0,... to trigger disproportionate CPU, memory, I/O, and bandwidth consumption per request. This results in a denial of service condition in Rack file-serving paths that process multipart byte range responses. Details Rack::Utils.getbyteranges accepts a comma-separated list of byte ranges and validates them based on their aggregate size, but does not impose a limit on how many individual ranges may be supplied. As a result, a request such as: can contain thousands of overlapping one-byte ranges while still satisfying the total-size check added for CVE-2024-26141. When such a header is processed by Rack’s file-serving code, each range causes additional…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x8cg-fq8g-mxfx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34826 Advisory: Rack's multipart byte range processing allows denial of service via excessive overlapping ranges IDs: CVE-2026-34826, GHSA-x8cg-fq8g-mxfx Record: https://patchnext.com/advisories/cve-2026-34826 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 3.2.6, 3.1.21, 2.2.23. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected < 2.2.23; >= 3.0.0.beta1, < 3.1.21; >= 3.2.0, < 3.2.6; fixed in 3.1.21, 2.2.23, 3.2.6 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x8cg-fq8g-mxfx (GitHub-reviewed advisory GHSA-x8cg-fq8g-mxfx lists affected ranges: RubyGems rack >=0 =3.0.0.beta1 =3.2.0 <3.2.6) Commands are suggestions: review each one before running it.
Loading voting…