Rack:: Static header_rules bypass via URL-encoded paths
CVE-2026-34786GHSA-q4qf-9j86-f5mh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.2.6, 3.1.21, 2.2.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- < 2.2.23>= 3.0.0.beta1, < 3.1.21>= 3.2.0, < 3.2.6
- Fixed in
- 3.1.21, 2.2.23, 3.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4qf-9j86-f5mh lists affected ranges: RubyGems rack >=0 =3.0.0.beta1 =3.2.0 <3.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-34786: 0.20% estimated exploitation activity in the next 30 days; percentile 10.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Rack::Static#applicablerules evaluates several headerrules types against the raw URL-encoded PATHINFO, while the underlying file-serving path is decoded before the file is served. As a result, a request for a URL-encoded variant of a static path can serve the same file without the headers that headerrules were intended to apply. In deployments that rely on Rack::Static to attach security-relevant response headers to static content, this can allow an attacker to bypass those headers by requesting an encoded form of the path. Details Rack::Static#applicablerules matches rule types such as :fonts, Array, and Regexp directly against the incoming PATHINFO. For example: These checks operate on the raw request path. If the request contains encoded characters such as %2E in place of ., the rule may fail to match even though the file path is later decoded and served successfully by the static file server. For example, both of the following requests may resolve to the same file on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q4qf-9j86-f5mh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34786 Advisory: Rack:: Static header_rules bypass via URL-encoded paths IDs: CVE-2026-34786, GHSA-q4qf-9j86-f5mh Record: https://patchnext.com/advisories/cve-2026-34786 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 3.2.6, 3.1.21, 2.2.23. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected < 2.2.23; >= 3.0.0.beta1, < 3.1.21; >= 3.2.0, < 3.2.6; fixed in 3.1.21, 2.2.23, 3.2.6 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q4qf-9j86-f5mh (GitHub-reviewed advisory GHSA-q4qf-9j86-f5mh lists affected ranges: RubyGems rack >=0 =3.0.0.beta1 =3.2.0 <3.2.6) Commands are suggestions: review each one before running it.
Loading voting…