Skip to content

← Actionable
Medium, CVSS 5.9amended

vLLM: Processing differential in multi-channel audio downmixing enables hidden-input/moderation bypass for audio models

CVE-2026-34760GHSA-6c4r-fmh3-7rh8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.5.5, < 0.18.0
    Fixed in
    0.18.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-34760: 0.28% estimated exploitation activity in the next 30 days; percentile 20.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Issue Description Librosa defaults to using numpy.mean for mono downmixing (tomono), while the international standard ITU-R BS.775-4 specifies a weighted downmixing algorithm. This discrepancy results in: - Inconsistency between audio heard by humans (e.g., through headphones/regular speakers) and audio processed by AI models (Which infra via Librosa, such as vllm, transformer). https://github.com/librosa/librosa/blob/af8c839fb15317fa2712ea66e7a22da6a9267b32/librosa/core/audio.py#L478 Attack Scenario and Impact LFE (Low-Frequency Effects) Channel Exploit Attackers can craft special multichannel audio files containing: 1. Normal content in front channels (L/R) 2. Either interference signals or hidden content in the LFE channel Notice: It is worth noting that not only the LFE channel is excluded, but in fact, channels beyond the 6th (such as rear surround channels, overhead channels, height speakers, etc.) are also not supported. Attack Methodology: Attackers can create specially…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6c4r-fmh3-7rh8

  2. Revision 1 · created ·

    Published from osv record GHSA-6c4r-fmh3-7rh8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34760

Advisory: vLLM: Processing differential in multi-channel audio downmixing enables hidden-input/moderation bypass for audio models
IDs: CVE-2026-34760, GHSA-6c4r-fmh3-7rh8
Record: https://patchnext.com/advisories/cve-2026-34760 (revision 2, source checked 26 Oct 2026, 13:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.5.5, < 0.18.0; fixed in 0.18.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6c4r-fmh3-7rh8 (OSV record GHSA-6c4r-fmh3-7rh8 lists affected ranges: PyPI vllm >=0.5.5 <0.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6c4r-fmh3-7rh8 (GitHub-reviewed advisory GHSA-6c4r-fmh3-7rh8 lists affected ranges: PyPI vllm >=0.5.5 <0.18.0)

Commands are suggestions: review each one before running it.

Loading voting…