Payload has a CSRF Protection Bypass in Authentication Flow
CVE-2026-34749GHSA-p6mr-xf3r-ghq4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 3.79.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm payload
- Affected
- < 3.79.1
- Fixed in
- 3.79.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p6mr-xf3r-ghq4 lists affected ranges: npm payload >=0 <3.79.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p6mr-xf3r-ghq4 lists affected ranges: npm payload >=0 <3.79.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-34749: 0.13% estimated exploitation activity in the next 30 days; percentile 2.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Cross-Site Request Forgery (CSRF) vulnerability existed in the authentication flow. Under certain conditions, the configured CSRF protection could be bypassed, allowing cross-site requests to be made. Consumers are affected if ALL of these are true: - Payload version < v3.79.1 - serverURL is configured Patches This vulnerability has been patched in v3.79.1. Additional validation has been added to the authentication flow. Consumers should upgrade to v3.79.1 or later. Workarounds There is no complete workaround without upgrading. If consumers cannot upgrade immediately, setting cookies.sameSite to 'Strict' will prevent the session cookie from being sent cross-site. However, this will also require users to re-authenticate when navigating to the application from external links (e.g. email, other sites).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p6mr-xf3r-ghq4
- Revision 1 · created ·
Published from osv record GHSA-p6mr-xf3r-ghq4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34749 Advisory: Payload has a CSRF Protection Bypass in Authentication Flow IDs: CVE-2026-34749, GHSA-p6mr-xf3r-ghq4 Record: https://patchnext.com/advisories/cve-2026-34749 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: payload 3.79.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm payload: affected < 3.79.1; fixed in 3.79.1 ## Suggested inspection (read-only) - `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on payload. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p6mr-xf3r-ghq4 (OSV record GHSA-p6mr-xf3r-ghq4 lists affected ranges: npm payload >=0 <3.79.1 (fixed)) - Verified: https://github.com/advisories/GHSA-p6mr-xf3r-ghq4 (GitHub-reviewed advisory GHSA-p6mr-xf3r-ghq4 lists affected ranges: npm payload >=0 <3.79.1) Commands are suggestions: review each one before running it.
Loading voting…