Payload has an SQL Injection via Query Handling
CVE-2026-34747GHSA-7xxh-373w-35vg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 3.79.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm payload
- Affected
- < 3.79.1
- Fixed in
- 3.79.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7xxh-373w-35vg lists affected ranges: npm payload >=0 <3.79.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7xxh-373w-35vg lists affected ranges: npm payload >=0 <3.79.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-34747: 0.32% estimated exploitation activity in the next 30 days; percentile 25.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Certain request inputs were not properly validated. An attacker could craft requests that influence SQL query execution, potentially exposing or modifying data in collections. Patches This issue has been fixed in v3.79.1 and later. Query input validation has been hardened. Upgrade to v3.79.1 or later. Workarounds Until developers can upgrade: - Limit access to endpoints that accept dynamic query inputs to trusted users only. - Validate or sanitize input from untrusted clients before sending it to query endpoints.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7xxh-373w-35vg
- Revision 1 · created ·
Published from osv record GHSA-7xxh-373w-35vg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34747 Advisory: Payload has an SQL Injection via Query Handling IDs: CVE-2026-34747, GHSA-7xxh-373w-35vg Record: https://patchnext.com/advisories/cve-2026-34747 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: payload 3.79.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm payload: affected < 3.79.1; fixed in 3.79.1 ## Suggested inspection (read-only) - `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on payload. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7xxh-373w-35vg (OSV record GHSA-7xxh-373w-35vg lists affected ranges: npm payload >=0 <3.79.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7xxh-373w-35vg (GitHub-reviewed advisory GHSA-7xxh-373w-35vg lists affected ranges: npm payload >=0 <3.79.1) Commands are suggestions: review each one before running it.
Loading voting…