Skip to content

← Actionable
High, CVSS 7.7amended

Payload has Authenticated SSRF via Upload Functionality

CVE-2026-34746GHSA-6r7f-q7f5-wpx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 3.79.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm payload

    Affected
    < 3.79.1
    Fixed in
    3.79.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-34746: 0.31% estimated exploitation activity in the next 30 days; percentile 23.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated Server-Side Request Forgery (SSRF) vulnerability existed in the upload functionality. Authenticated users with create or update access to an upload-enabled collection could cause the server to make outbound HTTP requests to arbitrary URLs. Consumers are affected if ALL of these are true: - Payload version < v3.79.1 - At least one collection with upload enabled - An authenticated user has create or update access to that collection Patches This vulnerability has been patched in v3.79.1. Users should upgrade to v3.79.1 or later. Workarounds Until consumers can upgrade: - Restrict create and update access to upload-enabled collections to trusted roles only. - Limit outbound network access from your Payload server where possible.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6r7f-q7f5-wpx8

  2. Revision 1 · created ·

    Published from osv record GHSA-6r7f-q7f5-wpx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34746

Advisory: Payload has Authenticated SSRF via Upload Functionality
IDs: CVE-2026-34746, GHSA-6r7f-q7f5-wpx8
Record: https://patchnext.com/advisories/cve-2026-34746 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: payload 3.79.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm payload: affected < 3.79.1; fixed in 3.79.1

## Suggested inspection (read-only)
- `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on payload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6r7f-q7f5-wpx8 (OSV record GHSA-6r7f-q7f5-wpx8 lists affected ranges: npm payload >=0 <3.79.1 (fixed))
- Verified: https://github.com/advisories/GHSA-6r7f-q7f5-wpx8 (GitHub-reviewed advisory GHSA-6r7f-q7f5-wpx8 lists affected ranges: npm payload >=0 <3.79.1)

Commands are suggestions: review each one before running it.

Loading voting…