Copier _external_data allows path traversal and absolute-path local file read without unsafe mode
CVE-2026-34730GHSA-hgjq-p8cr-gg4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (copier 9.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI copier
- Affected
- <= 9.14.0
- Fixed in
- 9.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hgjq-p8cr-gg4h lists affected ranges: PyPI copier >=0 <9.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hgjq-p8cr-gg4h lists affected ranges: PyPI copier >=0 <=9.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-34730: 0.30% estimated exploitation activity in the next 30 days; percentile 22.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Copier's externaldata feature allows a template to load YAML files using template-controlled paths. The documentation describes these values as relative paths from the subproject destination, so relative paths themselves appear to be part of the intended feature model. However, the current implementation also allows destination-external reads, including: - Parent-directory paths such as ../secret.yml - Absolute paths such as /tmp/secret.yml and then exposes the parsed contents in rendered output. This is possible without --UNSAFE, which makes the behavior potentially dangerous when Copier is run against untrusted templates. I am not certain this is unintended behavior, but it is security-sensitive and appears important to clarify. Details The relevant flow is: 1. A template defines externaldata 2. Copier renders the configured path string 3. Copier calls loadanswersfiledata(dstpath, renderedpath, warnonmissing=True) 4. loadanswersfiledata() opens Path(dstpath, answersfile)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hgjq-p8cr-gg4h
- Revision 1 · created ·
Published from osv record GHSA-hgjq-p8cr-gg4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34730 Advisory: Copier `_external_data` allows path traversal and absolute-path local file read without unsafe mode IDs: CVE-2026-34730, GHSA-hgjq-p8cr-gg4h Record: https://patchnext.com/advisories/cve-2026-34730 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: copier 9.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI copier: affected <= 9.14.0; fixed in 9.14.1 ## Suggested inspection (read-only) - `python -m pip show copier`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on copier. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hgjq-p8cr-gg4h (OSV record GHSA-hgjq-p8cr-gg4h lists affected ranges: PyPI copier >=0 <9.14.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hgjq-p8cr-gg4h (GitHub-reviewed advisory GHSA-hgjq-p8cr-gg4h lists affected ranges: PyPI copier >=0 <=9.14.0) Commands are suggestions: review each one before running it.
Loading voting…