phpMyFAQ: Stored XSS via Regex Bypass in Filter::removeAttributes()
CVE-2026-34729GHSA-cv2g-8cj8-vgc7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- <= 4.1.0
- Fixed in
- 4.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cv2g-8cj8-vgc7 lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 <=4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-34729: 0.25% estimated exploitation activity in the next 30 days; percentile 16.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The sanitization pipeline for FAQ content is: 1. Filter::filterVar($input, FILTERSANITIZESPECIALCHARS) — encodes <, , ", ', & to HTML entities 2. htmlentitydecode($input, ENTQUOTES | ENTHTML5) — decodes entities back to characters 3. Filter::removeAttributes($input) — removes dangerous HTML attributes The removeAttributes() regex at line 174 only matches attributes with double-quoted values: This regex does NOT match: - Attributes with single quotes: onerror='alert(1)' - Attributes without quotes: onerror=alert(1) An attacker can bypass sanitization by submitting FAQ content with unquoted or single-quoted event handler attributes. Details Affected File: phpmyfaq/src/phpMyFAQ/Filter.php, line 174 Sanitization flow for FAQ question field: FaqController::create() lines 110, 145-149: Template rendering: faq.twig line 36: How the bypass works: 1. Attacker submits: <img src=x onerror=alert(1) 2. After FILTERSANITIZESPECIALCHARS: <img src=x onerror=alert(1)> 3. After…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cv2g-8cj8-vgc7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34729 Advisory: phpMyFAQ: Stored XSS via Regex Bypass in Filter::removeAttributes() IDs: CVE-2026-34729, GHSA-cv2g-8cj8-vgc7 Record: https://patchnext.com/advisories/cve-2026-34729 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected <= 4.1.0; fixed in 4.1.1 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cv2g-8cj8-vgc7 (GitHub-reviewed advisory GHSA-cv2g-8cj8-vgc7 lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 <=4.1.0) Commands are suggestions: review each one before running it.
Loading voting…