Skip to content

← Actionable
Medium, CVSS 5.3amended

Parse Server has a LiveQuery protected-field guard bypass via array-like logical operator value

CVE-2026-34595GHSA-mmg8-87c5-jrc2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.7.0-alpha.16, 8.6.70), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.7.0-alpha.16< 8.6.70
    Fixed in
    9.7.0-alpha.16, 8.6.70

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-34595: 0.26% estimated exploitation activity in the next 30 days; percentile 17.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with find class-level permission can bypass the protectedFields class-level permission setting on LiveQuery subscriptions. By sending a subscription with a $or, $and, or $nor operator value as a plain object with numeric keys and a length property (an "array-like" object) instead of an array, the protected-field guard is bypassed. The subscription event firing acts as a binary oracle, allowing the attacker to infer whether a protected field matches a given test value. Patches The fix validates that $or, $and, and $nor operator values are arrays in the LiveQuery subscription handler, the query depth checker, and the protected-field guard. As defense in depth, the LiveQuery query evaluator also rejects non-array values for these operators. Workarounds There is no known workaround.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mmg8-87c5-jrc2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mmg8-87c5-jrc2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34595

Advisory: Parse Server has a LiveQuery protected-field guard bypass via array-like logical operator value
IDs: CVE-2026-34595, GHSA-mmg8-87c5-jrc2
Record: https://patchnext.com/advisories/cve-2026-34595 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.7.0-alpha.16, 8.6.70. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.7.0-alpha.16; < 8.6.70; fixed in 9.7.0-alpha.16, 8.6.70

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mmg8-87c5-jrc2 (OSV record GHSA-mmg8-87c5-jrc2 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.70 (fixed))
- Verified: https://github.com/advisories/GHSA-mmg8-87c5-jrc2 (GitHub-reviewed advisory GHSA-mmg8-87c5-jrc2 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.70)

Commands are suggestions: review each one before running it.

Loading voting…