Skip to content

← Actionable
High, CVSS 7.1amended

Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write

CVE-2026-34591GHSA-2599-h6xx-hpxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (poetry 2.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI poetry

    Affected
    >= 1.4.0, <= 2.3.2
    Fixed in
    2.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-34591: 0.49% estimated exploitation activity in the next 30 days; percentile 41.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A crafted wheel can contain ../ paths that Poetry writes to disk without containment checks, allowing arbitrary file write with the privileges of the Poetry process. Impact Arbitrary file write (path traversal) from untrusted wheel content. Impacts users/CI/CD systems installing malicious or compromised packages. Patches Versions 2.3.3 and newer of Poetry resolve the target paths and ensure that they are inside the target directory. Otherwise, installation is aborted. Details Poetry’s wheel destination path is built by directly joining an untrusted wheel entry path: src/poetry/installation/wheelinstaller.py:47 src/poetry/installation/wheelinstaller.py:59 The vulnerable sink is reachable in normal installation: src/poetry/installation/executor.py:607 No resolve() + isrelativeto() style guard is enforced before writing. POC

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2599-h6xx-hpxp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2599-h6xx-hpxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34591

Advisory: Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write
IDs: CVE-2026-34591, GHSA-2599-h6xx-hpxp
Record: https://patchnext.com/advisories/cve-2026-34591 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: poetry 2.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI poetry: affected >= 1.4.0, <= 2.3.2; fixed in 2.3.3

## Suggested inspection (read-only)
- `python -m pip show poetry`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on poetry.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2599-h6xx-hpxp (OSV record GHSA-2599-h6xx-hpxp lists affected ranges: PyPI poetry >=1.4.0 <2.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-2599-h6xx-hpxp (GitHub-reviewed advisory GHSA-2599-h6xx-hpxp lists affected ranges: PyPI poetry >=1.4.0 <=2.3.2)

Commands are suggestions: review each one before running it.

Loading voting…