OpenEXR: DWA Lossy Decoder Heap Out-of-Bounds Write
CVE-2026-34589GHSA-p8xc-w3q4-h64x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.4.9, 3.3.9, 3.2.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openexr
- Affected
- >= 3.2.0, < 3.2.7>= 3.3.0, < 3.3.9>= 3.4.0, < 3.4.9
- Fixed in
- 3.3.9, 3.2.7, 3.4.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p8xc-w3q4-h64x lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p8xc-w3q4-h64x lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-34589: 0.43% estimated exploitation activity in the next 30 days; percentile 36.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The DWA lossy decoder constructs temporary per-component block pointers using signed 32-bit arithmetic. For a large enough width, the calculation overflows and later decoder stores operate on a wrapped pointer outside the allocated rowBlock backing store. This bug is reachable from the public decoder path and can be reproduced through the shipped exrcheck tool with a crafted scanline DWAA file. The confirmed dynamic symptom is a write-side crash in the lossy DCT execution path. Tested on commit: 7820b7e1b93405ba1d551c43a945018226b75bc5 Root Cause and Data Flow The vulnerable pointer construction lives in src/lib/OpenEXRCore/internaldwadecoder.h: The expression numBlocksX 64 is computed as signed int. Once numBlocksX is large enough, the multiplication wraps, and rowBlock[comp] points backward rather than forward into the temporary decode buffer. Later, LossyDctDecoderexecute() uses those derived pointers for real loads and stores during the block shuffle and reconstruction…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p8xc-w3q4-h64x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p8xc-w3q4-h64x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34589 Advisory: OpenEXR: DWA Lossy Decoder Heap Out-of-Bounds Write IDs: CVE-2026-34589, GHSA-p8xc-w3q4-h64x Record: https://patchnext.com/advisories/cve-2026-34589 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openexr 3.4.9, 3.3.9, 3.2.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openexr: affected >= 3.2.0, < 3.2.7; >= 3.3.0, < 3.3.9; >= 3.4.0, < 3.4.9; fixed in 3.3.9, 3.2.7, 3.4.9 ## Suggested inspection (read-only) - `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openexr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p8xc-w3q4-h64x (OSV record GHSA-p8xc-w3q4-h64x lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.9 (fixed)) - Verified: https://github.com/advisories/GHSA-p8xc-w3q4-h64x (GitHub-reviewed advisory GHSA-p8xc-w3q4-h64x lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.9) Commands are suggestions: review each one before running it.
Loading voting…