OpenEXR has a signed 32-bit Overflow in PIZ Decoder Leads to OOB Read/Write
CVE-2026-34588GHSA-588r-cr5c-w6hf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.4.9, 3.3.9, 3.2.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openexr
- Affected
- >= 3.1.0, < 3.2.7>= 3.3.0, < 3.3.9>= 3.4.0, < 3.4.9
- Fixed in
- 3.3.9, 3.2.7, 3.4.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-588r-cr5c-w6hf lists affected ranges: PyPI openexr >=3.1.0 =3.3.0 =3.4.0 <3.4.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-588r-cr5c-w6hf lists affected ranges: PyPI openexr >=3.1.0 =3.3.0 =3.4.0 <3.4.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-34588: 0.50% estimated exploitation activity in the next 30 days; percentile 42.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary internalexrundopiz() advances the working wavelet pointer with signed 32-bit arithmetic: Because nx, ny, and wcount are int, a crafted EXR file can make this product overflow and wrap. The next channel then decodes from an incorrect address. The wavelet decode path operates in place, so this yields both out-of-bounds reads and out-of-bounds writes. Tested on commit 7820b7e1b93405ba1d551c43a945018226b75bc5 Technical Details The vulnerable decode path is: 1. internalexrundopiz() sets wavbuf = decode-scratchbuffer1. 2. For each channel, it calls wav2Ddecode (wavbuf + j, ...). 3. It then advances wavbuf with wavbuf += nx ny wcount. The overflow happens in step 3. Once wavbuf is wrapped, the next channel's wavelet decode runs on the wrong address. In the 14-bit wavelet path, wdec144() first reads: - px - p10 - p01 - p11 and then writes back to the same locations: - px = ... - p01 = ... - p10 = ... - p11 = ... As a result, the bug is not just a crash-only invalid read. It is an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-588r-cr5c-w6hf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-588r-cr5c-w6hf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34588 Advisory: OpenEXR has a signed 32-bit Overflow in PIZ Decoder Leads to OOB Read/Write IDs: CVE-2026-34588, GHSA-588r-cr5c-w6hf Record: https://patchnext.com/advisories/cve-2026-34588 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openexr 3.4.9, 3.3.9, 3.2.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openexr: affected >= 3.1.0, < 3.2.7; >= 3.3.0, < 3.3.9; >= 3.4.0, < 3.4.9; fixed in 3.3.9, 3.2.7, 3.4.9 ## Suggested inspection (read-only) - `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openexr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-588r-cr5c-w6hf (OSV record GHSA-588r-cr5c-w6hf lists affected ranges: PyPI openexr >=3.1.0 =3.3.0 =3.4.0 <3.4.9 (fixed)) - Verified: https://github.com/advisories/GHSA-588r-cr5c-w6hf (GitHub-reviewed advisory GHSA-588r-cr5c-w6hf lists affected ranges: PyPI openexr >=3.1.0 =3.3.0 =3.4.0 <3.4.9) Commands are suggestions: review each one before running it.
Loading voting…