Skip to content

← Actionable
Low, CVSS 2.0amended

mailparser vulnerable to Cross-site Scripting

CVE-2026-3455GHSA-7gmj-h9xc-mcxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mailparser 3.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2026-3455: 0.36% estimated exploitation activity in the next 30 days; percentile 30.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of the package mailparser before 3.9.3 are vulnerable to Cross-site Scripting (XSS) via the textToHtml() function due to the improper sanitisation of URLs in the email content. An attacker can execute arbitrary scripts in victim browsers by adding extra quote " to the URL with embedded malicious JavaScript code.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7gmj-h9xc-mcxc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7gmj-h9xc-mcxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-3455

Advisory: mailparser vulnerable to Cross-site Scripting
IDs: CVE-2026-3455, GHSA-7gmj-h9xc-mcxc
Record: https://patchnext.com/advisories/cve-2026-3455 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mailparser 3.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mailparser: affected < 3.9.3; fixed in 3.9.3

## Suggested inspection (read-only)
- `npm ls mailparser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mailparser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7gmj-h9xc-mcxc (OSV record GHSA-7gmj-h9xc-mcxc lists affected ranges: npm mailparser >=0 <3.9.3 (fixed))
- Verified: https://github.com/advisories/GHSA-7gmj-h9xc-mcxc (GitHub-reviewed advisory GHSA-7gmj-h9xc-mcxc lists affected ranges: npm mailparser >=0 <3.9.3)

Commands are suggestions: review each one before running it.

Loading voting…