OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl)
CVE-2026-34543GHSA-vc68-257w-m432
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openexr
- Affected
- >= 3.4.0, <= 3.4.7>= 3.3.0, <= 3.3.8>= 3.2.0, <= 3.2.6
- Fixed in
- 3.4.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vc68-257w-m432 lists affected ranges: PyPI openexr >=3.4.0 =3.3.0 =3.2.0 <=3.2.6
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vc68-257w-m432 lists affected ranges: PyPI openexr >=3.4.0 =3.3.0 =3.2.0 <=3.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-34543: 0.50% estimated exploitation activity in the next 30 days; percentile 42.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The PXR24 decompression function undopxr24impl in OpenEXR (internalpxr24.c) ignores the actual decompressed size (outSize) returned by exruncompressbuffer() and instead reads from the scratch buffer based solely on the expected size (uncompressedsize) derived from the header metadata. Additionally, exruncompressbuffer() (compression.c:202) treats LIBDEFLATESHORTOUTPUT (where the compressed stream decompresses to fewer bytes than expected) as a successful result rather than an error. When these two issues are combined, an attacker can craft a PXR24 EXR file containing a valid but truncated zlib stream. As a result, the decoder reads uninitialized heap memory and incorporates it into the output pixel data. Details This issue occurs due to the combination of two flaws. 1. compression.c:202–205 — LIBDEFLATESHORTOUTPUT treated as success libdeflatezlibdecompressex() returns LIBDEFLATESHORTOUTPUT when the compressed stream is successfully decompressed but the resulting output size…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vc68-257w-m432
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vc68-257w-m432
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34543 Advisory: OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl) IDs: CVE-2026-34543, GHSA-vc68-257w-m432 Record: https://patchnext.com/advisories/cve-2026-34543 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: openexr 3.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openexr: affected >= 3.4.0, <= 3.4.7; >= 3.3.0, <= 3.3.8; >= 3.2.0, <= 3.2.6; fixed in 3.4.8 ## Suggested inspection (read-only) - `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openexr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vc68-257w-m432 (OSV record GHSA-vc68-257w-m432 lists affected ranges: PyPI openexr >=3.4.0 =3.3.0 =3.2.0 <=3.2.6) - Verified: https://github.com/advisories/GHSA-vc68-257w-m432 (GitHub-reviewed advisory GHSA-vc68-257w-m432 lists affected ranges: PyPI openexr >=3.4.0 =3.3.0 =3.2.0 <=3.2.6) Commands are suggestions: review each one before running it.
Loading voting…