Apache Airflow has an authorization bypass in DagRun wait endpoint
CVE-2026-34538GHSA-r7vr-m4jw-r794
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- >= 3.0.0, < 3.2.0
- Fixed in
- 3.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r7vr-m4jw-r794 lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r7vr-m4jw-r794 lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-34538: 0.69% estimated exploitation activity in the next 30 days; percentile 52.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow versions 3.0.0 through 3.1.8 DagRun wait endpoint returns XCom result values even to users who only have DAG Run read permissions, such as the Viewer role.This behavior conflicts with the FAB RBAC model, which treats XCom as a separate protected resource, and with the security model documentation that defines the Viewer role as read-only. Airflow uses the FAB Auth Manager to manage access control on a per-resource basis. The Viewer role is intended to be read-only by default, and the security model documentation defines Viewer users as those who can inspect DAGs without accessing sensitive execution results. Users are recommended to upgrade to Apache Airflow 3.2.0 which resolves this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r7vr-m4jw-r794
- Revision 1 · created ·
Published from osv record GHSA-r7vr-m4jw-r794
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34538 Advisory: Apache Airflow has an authorization bypass in DagRun wait endpoint IDs: CVE-2026-34538, GHSA-r7vr-m4jw-r794 Record: https://patchnext.com/advisories/cve-2026-34538 (revision 2, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected >= 3.0.0, < 3.2.0; fixed in 3.2.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r7vr-m4jw-r794 (OSV record GHSA-r7vr-m4jw-r794 lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r7vr-m4jw-r794 (GitHub-reviewed advisory GHSA-r7vr-m4jw-r794 lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.0) Commands are suggestions: review each one before running it.
Loading voting…