File Browser is vulnerable to Stored Cross-site Scripting via crafted EPUB file
CVE-2026-34529GHSA-5vpr-4fgw-f69h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/filebrowser/filebrowser/v2 2.62.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/filebrowser/filebrowser/v2
- Affected
- <= 2.62.1
- Fixed in
- 2.62.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5vpr-4fgw-f69h lists affected ranges: Go github.com/filebrowser/filebrowser/v2 >=0 <=2.62.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-34529: 0.33% estimated exploitation activity in the next 30 days; percentile 25.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The EPUB preview function in File Browser is vulnerable to Stored Cross-site Scripting (XSS). JavaScript embedded in a crafted EPUB file executes in the victim's browser when they preview the file. Details frontend/src/views/files/Preview.vue passes allowScriptedContent: true to the vue-reader (epub.js) component: epub.js renders EPUB content inside a sandboxed <iframe with srcdoc. However, the sandbox includes both allow-scripts and allow-same-origin, which renders the sandbox ineffective — the script can access the parent frame's DOM and storage. The epub.js developers explicitly warn against enabling scripted content. PoC I've crafted the PoC python script that could be ran on test environment using docker compose: And running this PoC python script: And terminal output: <br/ Impact - JWT token theft — full session hijacking - Privilege escalation — a low-privilege user with upload (Create) permission can steal an admin's token
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5vpr-4fgw-f69h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34529 Advisory: File Browser is vulnerable to Stored Cross-site Scripting via crafted EPUB file IDs: CVE-2026-34529, GHSA-5vpr-4fgw-f69h Record: https://patchnext.com/advisories/cve-2026-34529 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/filebrowser/filebrowser/v2 2.62.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/filebrowser/filebrowser/v2: affected <= 2.62.1; fixed in 2.62.2 ## Suggested inspection (read-only) - Go github.com/filebrowser/filebrowser/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/filebrowser/filebrowser/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5vpr-4fgw-f69h (GitHub-reviewed advisory GHSA-5vpr-4fgw-f69h lists affected ranges: Go github.com/filebrowser/filebrowser/v2 >=0 <=2.62.1) Commands are suggestions: review each one before running it.
Loading voting…