SillyTavern: Incomplete IP validation in /api/search/visit allows SSRF via localhost and IPv6
CVE-2026-34526GHSA-wm7j-m6jm-8797
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sillytavern 1.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sillytavern
- Affected
- <= 1.16.0
- Fixed in
- 1.17.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wm7j-m6jm-8797 lists affected ranges: npm sillytavern >=0 <1.17.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wm7j-m6jm-8797 lists affected ranges: npm sillytavern >=0 <=1.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-34526: 0.22% estimated exploitation activity in the next 30 days; percentile 12.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Details Distinct from CVE-2025-59159 and CVE-2026-26286 (all fixed in v1.16.0). This endpoint is still unpatched. In src/endpoints/search.js line 419, the hostname is checked against /^\d+\.\d+\.\d+\.\d+$/. This only matches literal dotted-quad IPv4 (e.g. 127.0.0.1, 10.0.0.1). It does not catch: - localhost (hostname, not dotted-quad) - [::1] (IPv6 loopback) - DNS names resolving to internal addresses (e.g. localtest.me - 127.0.0.1) A separate port check (urlObj.port !== '') limits exploitation to services on default ports (80/443), making this lower severity than a fully unrestricted SSRF. PoC 1. Start SillyTavern v1.16.0 normally 2. Send requests to compare blocked vs bypassed (requires a valid session cookie or CSRF disabled): The 400 vs 500 difference confirms localhost and [::1] pass the IP check. The 500 is ECONNREFUSED (nothing listening on port 80), not a validation rejection. Impact Server-side request forgery with partial restrictions. An authenticated user can force the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wm7j-m6jm-8797
- Revision 1 · created ·
Published from osv record GHSA-wm7j-m6jm-8797
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34526 Advisory: SillyTavern: Incomplete IP validation in /api/search/visit allows SSRF via localhost and IPv6 IDs: CVE-2026-34526, GHSA-wm7j-m6jm-8797 Record: https://patchnext.com/advisories/cve-2026-34526 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sillytavern 1.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sillytavern: affected <= 1.16.0; fixed in 1.17.0 ## Suggested inspection (read-only) - `npm ls sillytavern --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sillytavern. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wm7j-m6jm-8797 (OSV record GHSA-wm7j-m6jm-8797 lists affected ranges: npm sillytavern >=0 <1.17.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wm7j-m6jm-8797 (GitHub-reviewed advisory GHSA-wm7j-m6jm-8797 lists affected ranges: npm sillytavern >=0 <=1.16.0) Commands are suggestions: review each one before running it.
Loading voting…