Skip to content

← Actionable
Medium, CVSS 5.3amended

SillyTavern: Path Traversal allows file existence oracle

CVE-2026-34523GHSA-525j-2hrj-m8fp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sillytavern 1.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-34523: 0.47% estimated exploitation activity in the next 30 days; percentile 40.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability in the static file route handler allows any unauthenticated user to determine whether files exist anywhere on the server's filesystem. By sending percent-encoded ../ sequences (%2E%2E%2F) in requests to static file routes, an attacker can check for the existence of files (404 if it doesn't exist, 403 means it exists). Details The vulnerability is in createRouteHandler (src/users.js:947–963), which backs all user-data static file routes: req.params[0] contains the raw (percent-encoded) wildcard from the URL. After decodeURIComponent, a request path like /characters/%2E%2E%2F%2E%2E%2FUsers/kirakira decodes to ../../Users/kirakira, and path.join resolves it outside the intended directory. res.sendFile correctly blocks the file from being served (the send module's root check returns 403), but fs.existsSync had already run, and the 403/404 distinction reveals the result. Affected routes (they all use the same handler, so they're all affected): -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-525j-2hrj-m8fp

  2. Revision 1 · created ·

    Published from osv record GHSA-525j-2hrj-m8fp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34523

Advisory: SillyTavern: Path Traversal allows file existence oracle
IDs: CVE-2026-34523, GHSA-525j-2hrj-m8fp
Record: https://patchnext.com/advisories/cve-2026-34523 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sillytavern 1.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sillytavern: affected <= 1.16.0; fixed in 1.17.0

## Suggested inspection (read-only)
- `npm ls sillytavern --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sillytavern.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-525j-2hrj-m8fp (OSV record GHSA-525j-2hrj-m8fp lists affected ranges: npm sillytavern >=0 <1.17.0 (fixed))
- Verified: https://github.com/advisories/GHSA-525j-2hrj-m8fp (GitHub-reviewed advisory GHSA-525j-2hrj-m8fp lists affected ranges: npm sillytavern >=0 <=1.16.0)

Commands are suggestions: review each one before running it.

Loading voting…