OpenClaw: Zalo webhook rate limiting could be bypassed before secret validation
CVE-2026-34505GHSA-5m9r-p9g7-679c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.3.11
- Fixed in
- 2026.3.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5m9r-p9g7-679c lists affected ranges: npm openclaw >=0 <2026.3.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5m9r-p9g7-679c lists affected ranges: npm openclaw >=0 <=2026.3.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-34505: 0.28% estimated exploitation activity in the next 30 days; percentile 20.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Zalo webhook handler applied request rate limiting only after webhook authentication succeeded. Requests with an invalid secret returned 401 but did not count against the rate limiter, allowing repeated secret guesses without triggering 429. Impact This made brute-force guessing materially easier for weak but policy-compliant webhook secrets. Once the secret was guessed, an attacker could submit forged Zalo webhook traffic. Affected versions openclaw <= 2026.3.11 Patch Fixed in openclaw 2026.3.12. Rate limiting now applies before successful authentication is required, closing the pre-auth brute-force gap. Users should update to 2026.3.12 or later and prefer strong webhook secrets.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5m9r-p9g7-679c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5m9r-p9g7-679c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34505 Advisory: OpenClaw: Zalo webhook rate limiting could be bypassed before secret validation IDs: CVE-2026-34505, GHSA-5m9r-p9g7-679c Record: https://patchnext.com/advisories/cve-2026-34505 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.12. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.3.11; fixed in 2026.3.12 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5m9r-p9g7-679c (OSV record GHSA-5m9r-p9g7-679c lists affected ranges: npm openclaw >=0 <2026.3.12 (fixed)) - Verified: https://github.com/advisories/GHSA-5m9r-p9g7-679c (GitHub-reviewed advisory GHSA-5m9r-p9g7-679c lists affected ranges: npm openclaw >=0 <=2026.3.11) Commands are suggestions: review each one before running it.
Loading voting…