Apache Tomcat vulnerable to Insertion of Sensitive Information into Log File
CVE-2026-34487GHSA-x4m4-345f-5h5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-tribes 11.0.21, 10.1.54, 9.0.117; org.apache.tomcat.embed:tomcat-embed-core 11.0.21, 10.1.54, 9.0.117; org.apache.tomcat:tomcat 11.0.21, 10.1.54, 9.0.117), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-tribes
- Affected
- >= 9.0.13, < 9.0.117>= 10.1.0-M1, < 10.1.54>= 11.0.0-M1, < 11.0.21
- Fixed in
- 9.0.117, 11.0.21, 10.1.54
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 9.0.13, < 9.0.117>= 10.1.0-M1, < 10.1.54>= 11.0.0-M1, < 11.0.21
- Fixed in
- 9.0.117, 11.0.21, 10.1.54
Maven org.apache.tomcat:tomcat
- Affected
- >= 9.0.13, < 9.0.117>= 10.1.0-M1, < 10.1.54>= 11.0.0-M1, < 11.0.21
- Fixed in
- 9.0.117, 11.0.21, 10.1.54
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x4m4-345f-5h5g lists affected ranges: Maven org.apache.tomcat:tomcat >=9.0.13 =10.1.0-M1 =11.0.0-M1 =9.0.13 =10.1.0-M1 =11.0.0-M1 =9.0.13 =10.1.0-M1 =11.0.0-M1 <11.0.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-34487: 0.45% estimated exploitation activity in the next 30 days; percentile 38.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Insertion of Sensitive Information into Log File vulnerability in the cloud membership for clustering component of Apache Tomcat exposed the Kubernetes bearer token. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.13 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x4m4-345f-5h5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34487 Advisory: Apache Tomcat vulnerable to Insertion of Sensitive Information into Log File IDs: CVE-2026-34487, GHSA-x4m4-345f-5h5g Record: https://patchnext.com/advisories/cve-2026-34487 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-tribes 11.0.21, 10.1.54, 9.0.117; org.apache.tomcat.embed:tomcat-embed-core 11.0.21, 10.1.54, 9.0.117; org.apache.tomcat:tomcat 11.0.21, 10.1.54, 9.0.117. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-tribes: affected >= 9.0.13, < 9.0.117; >= 10.1.0-M1, < 10.1.54; >= 11.0.0-M1, < 11.0.21; fixed in 9.0.117, 11.0.21, 10.1.54 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.13, < 9.0.117; >= 10.1.0-M1, < 10.1.54; >= 11.0.0-M1, < 11.0.21; fixed in 9.0.117, 11.0.21, 10.1.54 - Maven org.apache.tomcat:tomcat: affected >= 9.0.13, < 9.0.117; >= 10.1.0-M1, < 10.1.54; >= 11.0.0-M1, < 11.0.21; fixed in 9.0.117, 11.0.21, 10.1.54 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-tribes: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-tribes, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x4m4-345f-5h5g (GitHub-reviewed advisory GHSA-x4m4-345f-5h5g lists affected ranges: Maven org.apache.tomcat:tomcat >=9.0.13 =10.1.0-M1 =11.0.0-M1 =9.0.13 =10.1.0-M1 =11.0.0-M1 =9.0.13 =10.1.0-M1 =11.0.0-M1 <11.0.21) Commands are suggestions: review each one before running it.
Loading voting…