Skip to content

← Actionable
High, CVSS 7.5Exploited · CISA KEV

Apache Tomcat Missing Encryption of Sensitive Data vulnerability

CVE-2026-34486GHSA-69r9-qgr7-g2wj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-tribes 11.0.21, 10.1.54, 9.0.117; org.apache.tomcat:tomcat 11.0.21, 10.1.54, 9.0.117), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat-tribes

    Affected
    >= 11.0.20, <= 11.0.20>= 10.1.53, <= 10.1.53>= 9.0.116, <= 9.0.116
    Fixed in
    9.0.117, 11.0.21, 10.1.54
  • Maven org.apache.tomcat:tomcat

    Affected
    >= 11.0.20, <= 11.0.20>= 10.1.53, <= 10.1.53>= 9.0.116, <= 9.0.116
    Fixed in
    9.0.117, 11.0.21, 10.1.54

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-69r9-qgr7-g2wj lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.20 =10.1.53 =9.0.116 =11.0.20 =10.1.53 =9.0.116 <=9.0.116

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

  • CISA Known Exploited Vulnerabilities Catalog

    CISA added CVE-2026-34486 to the Known Exploited Vulnerabilities catalog on 2026-08-04.

    VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-08-04).

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-34486: 98.50% estimated exploitation activity in the next 30 days; percentile 99.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor. This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-69r9-qgr7-g2wj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34486

Advisory: Apache Tomcat Missing Encryption of Sensitive Data vulnerability
IDs: CVE-2026-34486, GHSA-69r9-qgr7-g2wj
Record: https://patchnext.com/advisories/cve-2026-34486 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-tribes 11.0.21, 10.1.54, 9.0.117; org.apache.tomcat:tomcat 11.0.21, 10.1.54, 9.0.117. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-tribes: affected >= 11.0.20, <= 11.0.20; >= 10.1.53, <= 10.1.53; >= 9.0.116, <= 9.0.116; fixed in 9.0.117, 11.0.21, 10.1.54
- Maven org.apache.tomcat:tomcat: affected >= 11.0.20, <= 11.0.20; >= 10.1.53, <= 10.1.53; >= 9.0.116, <= 9.0.116; fixed in 9.0.117, 11.0.21, 10.1.54

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-tribes: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-tribes, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-69r9-qgr7-g2wj (GitHub-reviewed advisory GHSA-69r9-qgr7-g2wj lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.20 =10.1.53 =9.0.116 =11.0.20 =10.1.53 =9.0.116 <=9.0.116)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-34486 to the Known Exploited Vulnerabilities catalog on 2026-08-04.)

Commands are suggestions: review each one before running it.

Loading voting…