Skip to content

← Actionable
High, CVSS 7.5

Apache Tomcat has an Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve

CVE-2026-34483GHSA-rv64-5gf8-9qq8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-catalina 11.0.21, 10.1.54, 9.0.116; org.apache.tomcat.embed:tomcat-embed-core 11.0.21, 10.1.54, 9.0.116; org.apache.tomcat:tomcat 11.0.21, 10.1.54, 9.0.116), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-rv64-5gf8-9qq8 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=9.0.40 =10.1.0-M1 =11.0.0-M1 =9.0.40 =10.1.0-M1 =11.0.0-M1 =9.0.40 =10.1.0-M1 =11.0.0-M1 <11.0.21

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-34483: 0.46% estimated exploitation activity in the next 30 days; percentile 40.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.40 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117 , which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rv64-5gf8-9qq8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34483

Advisory: Apache Tomcat has an Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve
IDs: CVE-2026-34483, GHSA-rv64-5gf8-9qq8
Record: https://patchnext.com/advisories/cve-2026-34483 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.21, 10.1.54, 9.0.116; org.apache.tomcat.embed:tomcat-embed-core 11.0.21, 10.1.54, 9.0.116; org.apache.tomcat:tomcat 11.0.21, 10.1.54, 9.0.116. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-catalina: affected >= 9.0.40, < 9.0.116; >= 10.1.0-M1, < 10.1.54; >= 11.0.0-M1, < 11.0.21; fixed in 9.0.116, 11.0.21, 10.1.54
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.40, < 9.0.116; >= 10.1.0-M1, < 10.1.54; >= 11.0.0-M1, < 11.0.21; fixed in 9.0.116, 11.0.21, 10.1.54
- Maven org.apache.tomcat:tomcat: affected >= 9.0.40, < 9.0.116; >= 10.1.0-M1, < 10.1.54; >= 11.0.0-M1, < 11.0.21; fixed in 9.0.116, 11.0.21, 10.1.54

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rv64-5gf8-9qq8 (GitHub-reviewed advisory GHSA-rv64-5gf8-9qq8 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=9.0.40 =10.1.0-M1 =11.0.0-M1 =9.0.40 =10.1.0-M1 =11.0.0-M1 =9.0.40 =10.1.0-M1 =11.0.0-M1 <11.0.21)

Commands are suggestions: review each one before running it.

Loading voting…