OAuth2 Proxy's Health Check User-Agent Matching Bypasses Authentication in auth_request Mode
CVE-2026-34457GHSA-5hvv-m4w4-gf6v
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/oauth2-proxy/oauth2-proxy
- Affected
- <= 3.2.0
- Fixed in
- no fixed version recorded
Go github.com/oauth2-proxy/oauth2-proxy/v7
- Affected
- < 7.15.2
- Fixed in
- 7.15.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hvv-m4w4-gf6v lists affected ranges: Go github.com/oauth2-proxy/oauth2-proxy/v7 >=0 =0 <=3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-34457: 0.47% estimated exploitation activity in the next 30 days; percentile 41.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A configuration-dependent authentication bypass exists in OAuth2 Proxy. Deployments are affected when all of the following are true: - OAuth2 Proxy is used with an authrequest-style integration (for example, nginx authrequest) - --ping-user-agent is set or --gcp-healthchecks is enabled In affected configurations, OAuth2 Proxy will treat a request with the configured health check User-Agent value as a successful health check regardless of the requested path. This allows an unauthenticated remote attacker to bypass authentication and access protected upstream resources without completing the normal login flow. This issue does not affect deployments that do not use authrequest-style subrequests, or that do not enable --ping-user-agent/--gcp-healthchecks. Patches Users should upgrade to v7.15.2 or later once available. Deployments running versions prior to v7.15.2 should be considered affected if they use authrequest-style authentication together with --ping-user-agent or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5hvv-m4w4-gf6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34457 Advisory: OAuth2 Proxy's Health Check User-Agent Matching Bypasses Authentication in auth_request Mode IDs: CVE-2026-34457, GHSA-5hvv-m4w4-gf6v Record: https://patchnext.com/advisories/cve-2026-34457 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/oauth2-proxy/oauth2-proxy/v7 7.15.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/oauth2-proxy/oauth2-proxy: affected <= 3.2.0 - Go github.com/oauth2-proxy/oauth2-proxy/v7: affected < 7.15.2; fixed in 7.15.2 ## Suggested inspection (read-only) - Go github.com/oauth2-proxy/oauth2-proxy: check the installed version with your package manager. - Go github.com/oauth2-proxy/oauth2-proxy/v7: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/oauth2-proxy/oauth2-proxy, github.com/oauth2-proxy/oauth2-proxy/v7. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5hvv-m4w4-gf6v (GitHub-reviewed advisory GHSA-5hvv-m4w4-gf6v lists affected ranges: Go github.com/oauth2-proxy/oauth2-proxy/v7 >=0 =0 <=3.2.0) Commands are suggestions: review each one before running it.
Loading voting…