Skip to content

← Actionable
Medium, CVSS 4.8amended

Claude SDK for Python has Insecure Default File Permissions in Local Filesystem Memory Tool

CVE-2026-34450GHSA-q5f5-3gjm-7mfm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (anthropic 0.87.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI anthropic

    Affected
    >= 0.86.0, < 0.87.0
    Fixed in
    0.87.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-34450: 0.13% estimated exploitation activity in the next 30 days; percentile 2.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The local filesystem memory tool in the Anthropic Python SDK created memory files with mode 0o666, leaving them world-readable on systems with a standard umask and world-writable in environments with a permissive umask such as many Docker base images. A local attacker on a shared host could read persisted agent state, and in containerized deployments could modify memory files to influence subsequent model behavior. Both the synchronous and asynchronous memory tool implementations were affected. Users on the affected versions are advised to update to the latest version. Claude SDK for Python thanks lucasfutures on HackerOne for the report.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q5f5-3gjm-7mfm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q5f5-3gjm-7mfm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34450

Advisory: Claude SDK for Python has Insecure Default File Permissions in Local Filesystem Memory Tool
IDs: CVE-2026-34450, GHSA-q5f5-3gjm-7mfm
Record: https://patchnext.com/advisories/cve-2026-34450 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: anthropic 0.87.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI anthropic: affected >= 0.86.0, < 0.87.0; fixed in 0.87.0

## Suggested inspection (read-only)
- `python -m pip show anthropic`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on anthropic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q5f5-3gjm-7mfm (OSV record GHSA-q5f5-3gjm-7mfm lists affected ranges: PyPI anthropic >=0.86.0 <0.87.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q5f5-3gjm-7mfm (GitHub-reviewed advisory GHSA-q5f5-3gjm-7mfm lists affected ranges: PyPI anthropic >=0.86.0 <0.87.0)

Commands are suggestions: review each one before running it.

Loading voting…