alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API
CVE-2026-34400GHSA-8prr-286p-4w7j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (alerta-server 9.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI alerta-server
- Affected
- < 9.1.0
- Fixed in
- 9.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8prr-286p-4w7j lists affected ranges: PyPI alerta-server >=0 <9.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8prr-286p-4w7j lists affected ranges: PyPI alerta-server >=0 <9.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-34400: 0.53% estimated exploitation activity in the next 30 days; percentile 44.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. Patches Fixed in v9.1.0. The Postgres query parser now uses parameterized queries with %(name)s placeholders passed to psycopg2's cursor.execute(), preventing SQL injection through the ?q= parameter. The MongoDB backend was not affected. Workarounds Upgrade to v9.1.0 or later. If unable to upgrade, deploy a proxy in front of the Alerta API to sanitize the q= parameter. Resources https://github.com/alerta/alerta/pull/712/files https://owasp.org/www-community/attacks/SQLInjection
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8prr-286p-4w7j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8prr-286p-4w7j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34400 Advisory: alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API IDs: CVE-2026-34400, GHSA-8prr-286p-4w7j Record: https://patchnext.com/advisories/cve-2026-34400 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: alerta-server 9.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI alerta-server: affected < 9.1.0; fixed in 9.1.0 ## Suggested inspection (read-only) - `python -m pip show alerta-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on alerta-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8prr-286p-4w7j (OSV record GHSA-8prr-286p-4w7j lists affected ranges: PyPI alerta-server >=0 <9.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8prr-286p-4w7j (GitHub-reviewed advisory GHSA-8prr-286p-4w7j lists affected ranges: PyPI alerta-server >=0 <9.1.0) Commands are suggestions: review each one before running it.
Loading voting…