Fleet vulnerable to SQL Injection in MDM bootstrap package by authenticated team or global admin
CVE-2026-34386GHSA-9p23-p2m4-2r4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fleetdm/fleet/v4 4.81.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/fleetdm/fleet/v4
- Affected
- < 4.81.0
- Fixed in
- 4.81.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9p23-p2m4-2r4m lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <4.81.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-34386: 0.33% estimated exploitation activity in the next 30 days; percentile 26.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A SQL Injection vulnerability in Fleet's MDM bootstrap package configuration allows an authenticated user with Team Admin or Global Admin privileges to modify arbitrary team configurations, exfiltrate sensitive data from the Fleet database, and inject arbitrary content into team configs via direct API calls. Impact An authenticated user with Team Admin or Global Admin role can exploit a flaw in how user-supplied input is handled during MDM bootstrap package configuration. Insufficient server-side input validation allows crafted input to manipulate database queries in unintended ways. Successful exploitation could enable cross-team data corruption, exfiltration of sensitive information such as password hashes and API tokens, and potential privilege escalation. Exploitation requires authentication with team or global admin privileges and MDM to be enabled. This issue does not affect instances where Apple MDM is disabled. Workarounds If an immediate upgrade is not possible,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9p23-p2m4-2r4m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34386 Advisory: Fleet vulnerable to SQL Injection in MDM bootstrap package by authenticated team or global admin IDs: CVE-2026-34386, GHSA-9p23-p2m4-2r4m Record: https://patchnext.com/advisories/cve-2026-34386 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/fleetdm/fleet/v4 4.81.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/fleetdm/fleet/v4: affected < 4.81.0; fixed in 4.81.0 ## Suggested inspection (read-only) - Go github.com/fleetdm/fleet/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/fleetdm/fleet/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9p23-p2m4-2r4m (GitHub-reviewed advisory GHSA-9p23-p2m4-2r4m lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <4.81.0) Commands are suggestions: review each one before running it.
Loading voting…