Zebra has a Consensus Failure due to Improper Verification of V5 Transactions
CVE-2026-34377GHSA-3vmh-33xr-9cqh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zebra-consensus 5.0.1; zebrad 4.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io zebra-consensus
- Affected
- < 5.0.1
- Fixed in
- 5.0.1
crates.io zebrad
- Affected
- < 4.3.0
- Fixed in
- 4.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3vmh-33xr-9cqh lists affected ranges: crates.io zebrad >=0 =0 <5.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H · score source
- EPSS
- CVE-2026-34377: 0.26% estimated exploitation activity in the next 30 days; percentile 17.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
--- CVE-2026-34377: Consensus Failure via Crafted V5 Authorization Data Summary A logic error in Zebra's transaction verification cache could allow a malicious miner to induce a consensus split. By matching a valid transaction's txid while providing invalid authorization data, a miner could cause vulnerable Zebra nodes to accept an invalid block, leading to a consensus split from the rest of the Zcash network. To be clear, this would not allow invalid transactions to be accepted but could result in a consensus split between vulnerable Zebra nodes and invulnerable Zebra and Zcashd nodes. Severity High - This is a Consensus Vulnerability that could allow a malicious miner to induce network partitioning, service disruption, and potential double-spend attacks against affected nodes. Affected Versions All Zebra versions supporting V5 transactions (Network Upgrade 5 and later) prior to version 4.3.0. Description The vulnerability exists in the findverifiedunminedtx function within…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3vmh-33xr-9cqh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34377 Advisory: Zebra has a Consensus Failure due to Improper Verification of V5 Transactions IDs: CVE-2026-34377, GHSA-3vmh-33xr-9cqh Record: https://patchnext.com/advisories/cve-2026-34377 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zebra-consensus 5.0.1; zebrad 4.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io zebra-consensus: affected < 5.0.1; fixed in 5.0.1 - crates.io zebrad: affected < 4.3.0; fixed in 4.3.0 ## Suggested inspection (read-only) - crates.io zebra-consensus: check the installed version with your package manager. - crates.io zebrad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zebra-consensus, zebrad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3vmh-33xr-9cqh (GitHub-reviewed advisory GHSA-3vmh-33xr-9cqh lists affected ranges: crates.io zebrad >=0 =0 <5.0.1) Commands are suggestions: review each one before running it.
Loading voting…