Skip to content

← Actionable
High, CVSS 8.2amended

LiveQuery protected field leak via shared mutable state across concurrent subscribers

CVE-2026-34363GHSA-m983-v2ff-wq65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.7.0-alpha.9, 8.6.65), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.7.0-alpha.9< 8.6.65
    Fixed in
    8.6.65, 9.7.0-alpha.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-34363: 0.37% estimated exploitation activity in the next 30 days; percentile 31.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When multiple clients subscribe to the same class via LiveQuery, the event handlers process each subscriber concurrently using shared mutable objects. The sensitive data filter modifies these shared objects in-place, so when one subscriber's filter removes a protected field, subsequent subscribers may receive the already-filtered object. This can cause protected fields and authentication data to leak to clients that should not see them, or cause clients that should see the data to receive an incomplete object. Additionally, when an afterEvent Cloud Code trigger is registered, one subscriber's trigger modifications can leak to other subscribers through the same shared mutable state. Any Parse Server deployment using LiveQuery with protected fields or afterEvent triggers is affected when multiple clients subscribe to the same class. Patches The fix deep-clones the shared objects at the start of each subscriber's processing callback, ensuring each subscriber works on an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m983-v2ff-wq65

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m983-v2ff-wq65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34363

Advisory: LiveQuery protected field leak via shared mutable state across concurrent subscribers
IDs: CVE-2026-34363, GHSA-m983-v2ff-wq65
Record: https://patchnext.com/advisories/cve-2026-34363 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.7.0-alpha.9, 8.6.65. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.7.0-alpha.9; < 8.6.65; fixed in 8.6.65, 9.7.0-alpha.9

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m983-v2ff-wq65 (OSV record GHSA-m983-v2ff-wq65 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.65 (fixed))
- Verified: https://github.com/advisories/GHSA-m983-v2ff-wq65 (GitHub-reviewed advisory GHSA-m983-v2ff-wq65 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.65)

Commands are suggestions: review each one before running it.

Loading voting…