Skip to content

← Actionable
High, CVSS 8.2

Auth0 PHP SDK has Insufficient Entropy in Cookie Encryption

CVE-2026-34236GHSA-w3wc-44p4-m4j7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/auth0-php 8.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-34236: 0.22% estimated exploitation activity in the next 30 days; percentile 13.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. Am I Affected? Consumers are affected if their application meets the following preconditions: - Their application is using the Auth0-PHP SDK, versions between 8.0.0 and 8.18.0 - Their application is using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK: - Auth0/symfony, - Auth0/laravel0-auth0, or - Auth0/wordpress Resolution Upgrade Auth0/Auth0-PHP to version 8.19.0 or greater.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w3wc-44p4-m4j7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34236

Advisory: Auth0 PHP SDK has Insufficient Entropy in Cookie Encryption
IDs: CVE-2026-34236, GHSA-w3wc-44p4-m4j7
Record: https://patchnext.com/advisories/cve-2026-34236 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0/auth0-php 8.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist auth0/auth0-php: affected >= 8.0.0, <= 8.18.0; fixed in 8.19.0

## Suggested inspection (read-only)
- Packagist auth0/auth0-php: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0/auth0-php.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w3wc-44p4-m4j7 (GitHub-reviewed advisory GHSA-w3wc-44p4-m4j7 lists affected ranges: Packagist auth0/auth0-php >=8.0.0 <=8.18.0)

Commands are suggestions: review each one before running it.

Loading voting…