Slippers Vulnerable to Cross-Site Scripting (XSS) in attrs Template Tag
CVE-2026-34231GHSA-w7rv-gfp4-j9j3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (slippers 0.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI slippers
- Affected
- <= 0.6.2
- Fixed in
- 0.6.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w7rv-gfp4-j9j3 lists affected ranges: PyPI slippers >=0 <0.6.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w7rv-gfp4-j9j3 lists affected ranges: PyPI slippers >=0 <=0.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-34231: 0.24% estimated exploitation activity in the next 30 days; percentile 14.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Cross-site Scripting (XSS) vulnerability exists in the {% attrs %} template tag of the slippers Django package. When a context variable containing untrusted data is passed to {% attrs %}, the value is interpolated into an HTML attribute string without escaping, allowing an attacker to break out of the attribute context and inject arbitrary HTML or JavaScript into the rendered page. Vulnerability details Root cause AttrsNode is a custom Node subclass registered via register.tag(). Unlike register.simpletag(), which automatically applies conditionalescape() when autoescape is on, custom Node.render() methods receive no automatic escaping and are fully responsible for sanitising their output. attrstring() fails to do this: Attack scenario Given a template that uses {% attrs %} with a user-supplied value: An attacker crafting a request with q=" onmouseover="alert(document.cookie)" x=" produces: Impact Any template that passes values derived from user input, database content, or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w7rv-gfp4-j9j3
- Revision 1 · created ·
Published from osv record GHSA-w7rv-gfp4-j9j3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34231 Advisory: Slippers Vulnerable to Cross-Site Scripting (XSS) in `attrs` Template Tag IDs: CVE-2026-34231, GHSA-w7rv-gfp4-j9j3 Record: https://patchnext.com/advisories/cve-2026-34231 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: slippers 0.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI slippers: affected <= 0.6.2; fixed in 0.6.3 ## Suggested inspection (read-only) - `python -m pip show slippers`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on slippers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w7rv-gfp4-j9j3 (OSV record GHSA-w7rv-gfp4-j9j3 lists affected ranges: PyPI slippers >=0 <0.6.3 (fixed)) - Verified: https://github.com/advisories/GHSA-w7rv-gfp4-j9j3 (GitHub-reviewed advisory GHSA-w7rv-gfp4-j9j3 lists affected ranges: PyPI slippers >=0 <=0.6.2) Commands are suggestions: review each one before running it.
Loading voting…