Skip to content

← Actionable
High, CVSS 7.5

Rack has quadratic complexity in Rack::Utils.select_best_encoding via wildcard Accept-Encoding header

CVE-2026-34230GHSA-v569-hp3g-36wr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.2.6, 3.1.21, 2.2.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack

    Affected
    < 2.2.23>= 3.0.0.beta1, < 3.1.21>= 3.2.0, < 3.2.6
    Fixed in
    3.1.21, 2.2.23, 3.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-34230: 0.45% estimated exploitation activity in the next 30 days; percentile 38.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Rack::Utils.selectbestencoding processes Accept-Encoding values with quadratic time complexity when the header contains many wildcard () entries. Because this method is used by Rack::Deflater to choose a response encoding, an unauthenticated attacker can send a single request with a crafted Accept-Encoding header and cause disproportionate CPU consumption on the compression middleware path. This results in a denial of service condition for applications using Rack::Deflater. Details Rack::Utils.selectbestencoding expands parsed Accept-Encoding values into a list of candidate encodings. When an entry is , the method computes the set of concrete encodings by subtracting the encodings already present in the request: Because acceptencoding.map(&:first) is evaluated inside the loop, it is recomputed for each wildcard entry. If the request contains N wildcard entries, this produces repeated scans over the full parsed header and causes quadratic behavior. After expansion, the method…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v569-hp3g-36wr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34230

Advisory: Rack has quadratic complexity in Rack::Utils.select_best_encoding via wildcard Accept-Encoding header
IDs: CVE-2026-34230, GHSA-v569-hp3g-36wr
Record: https://patchnext.com/advisories/cve-2026-34230 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack 3.2.6, 3.1.21, 2.2.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack: affected < 2.2.23; >= 3.0.0.beta1, < 3.1.21; >= 3.2.0, < 3.2.6; fixed in 3.1.21, 2.2.23, 3.2.6

## Suggested inspection (read-only)
- RubyGems rack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v569-hp3g-36wr (GitHub-reviewed advisory GHSA-v569-hp3g-36wr lists affected ranges: RubyGems rack >=0 =3.0.0.beta1 =3.2.0 <3.2.6)

Commands are suggestions: review each one before running it.

Loading voting…