MikroORM is vulnerable to SQL Injection via specially crafted object
CVE-2026-34220GHSA-gwhv-j974-6fxm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@mikro-orm/core 7.0.6, 6.6.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @mikro-orm/core
- Affected
- < 6.6.10>= 7.0.0-dev.0, < 7.0.6
- Fixed in
- 6.6.10, 7.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwhv-j974-6fxm lists affected ranges: npm @mikro-orm/core >=0 =7.0.0-dev.0 <7.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gwhv-j974-6fxm lists affected ranges: npm @mikro-orm/core >=0 =7.0.0-dev.0 <7.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-34220: 0.43% estimated exploitation activity in the next 30 days; percentile 37.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary MikroORM versions <= 6.6.9 and <= 7.0.5 are vulnerable to SQL injection when specially crafted objects are interpreted as raw SQL query fragments. Impact If user-controlled input is passed directly to MikroORM query construction APIs, an attacker may inject raw SQL fragments. This can lead to SQL injection depending on the database and query being executed. Affected usage The issue occurs when untrusted objects are passed to ORM write APIs such as: - wrap(entity).assign(userInput) followed by em.flush() - em.nativeUpdate() - em.nativeInsert() - em.create() followed by em.flush() Applications that validate input types or enforce strict schema validation before passing data to MikroORM are not affected. Fix The vulnerability was caused by duck-typed detection of internal ORM marker properties. The fix replaces these checks with symbol-based markers that cannot be reproduced by user input.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-gwhv-j974-6fxm
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-gwhv-j974-6fxm
- Revision 1 · created ·
Published from ghsa record GHSA-gwhv-j974-6fxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34220 Advisory: MikroORM is vulnerable to SQL Injection via specially crafted object IDs: CVE-2026-34220, GHSA-gwhv-j974-6fxm Record: https://patchnext.com/advisories/cve-2026-34220 (revision 4, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @mikro-orm/core 7.0.6, 6.6.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @mikro-orm/core: affected < 6.6.10; >= 7.0.0-dev.0, < 7.0.6; fixed in 6.6.10, 7.0.6 ## Suggested inspection (read-only) - `npm ls @mikro-orm/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @mikro-orm/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gwhv-j974-6fxm (GitHub-reviewed advisory GHSA-gwhv-j974-6fxm lists affected ranges: npm @mikro-orm/core >=0 =7.0.0-dev.0 <7.0.6) - Verified: https://osv.dev/vulnerability/GHSA-gwhv-j974-6fxm (OSV record GHSA-gwhv-j974-6fxm lists affected ranges: npm @mikro-orm/core >=0 =7.0.0-dev.0 <7.0.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…