Skip to content

← Actionable
High, CVSS 8.2

libp2p-gossipsub: Remote crash via unchecked Instant overflow in heartbeat backoff expiry handling

CVE-2026-34219GHSA-xqmp-fxgv-xvq5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (libp2p-gossipsub 0.49.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-34219: 0.58% estimated exploitation activity in the next 30 days; percentile 47.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Summary The Rust libp2p Gossipsub implementation contains a remotely reachable panic in backoff expiry handling. After a peer sends a crafted PRUNE control message with an attacker-controlled, near-maximum backoff value, the value is accepted and stored as an Instant near the representable upper bound. On a later heartbeat, the implementation performs unchecked Instant + Duration arithmetic (backofftime + slack), which can overflow and panic with: overflow when adding duration to instant This issue is reachable from any Gossipsub peer over normal TCP + Noise + mplex/yamux connectivity and requires no further authentication beyond becoming a protocol peer. Attack Scenario An attacker that can establish a libp2p Gossipsub session with a target node can crash the target by sending crafted PRUNE control data: 1. Establish a standard libp2p session (TCP + Noise) and negotiate a stream multiplexer (mplex/yamux). 2. Open a Gossipsub stream and send an RPC containing ControlPrune…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xqmp-fxgv-xvq5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34219

Advisory: libp2p-gossipsub: Remote crash via unchecked Instant overflow in heartbeat backoff expiry handling
IDs: CVE-2026-34219, GHSA-xqmp-fxgv-xvq5
Record: https://patchnext.com/advisories/cve-2026-34219 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: libp2p-gossipsub 0.49.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io libp2p-gossipsub: affected < 0.49.4; fixed in 0.49.4

## Suggested inspection (read-only)
- crates.io libp2p-gossipsub: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on libp2p-gossipsub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xqmp-fxgv-xvq5 (GitHub-reviewed advisory GHSA-xqmp-fxgv-xvq5 lists affected ranges: crates.io libp2p-gossipsub >=0 <0.49.4)

Commands are suggestions: review each one before running it.

Loading voting…