Parse Server exposes auth data via verify password endpoint
CVE-2026-34215GHSA-wp76-gg32-8258
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.7.0-alpha.7, 8.6.63), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.7.0-alpha.7< 8.6.63
- Fixed in
- 8.6.63, 9.7.0-alpha.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wp76-gg32-8258 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.63 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wp76-gg32-8258 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.63
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-34215: 0.31% estimated exploitation activity in the next 30 days; percentile 24.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The verify password endpoint returns unsanitized authentication data, including MFA TOTP secrets, recovery codes, and OAuth access tokens. An attacker who knows a user's password can extract the MFA secret to generate valid MFA codes, defeating multi-factor authentication protection. Patches The verify password endpoint now sanitizes authentication data through auth adapter hooks before returning the response, consistent with login and user retrieval endpoints. Workarounds There is no known workaround.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wp76-gg32-8258
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wp76-gg32-8258
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34215 Advisory: Parse Server exposes auth data via verify password endpoint IDs: CVE-2026-34215, GHSA-wp76-gg32-8258 Record: https://patchnext.com/advisories/cve-2026-34215 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.7.0-alpha.7, 8.6.63. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.7.0-alpha.7; < 8.6.63; fixed in 8.6.63, 9.7.0-alpha.7 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wp76-gg32-8258 (OSV record GHSA-wp76-gg32-8258 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.63 (fixed)) - Verified: https://github.com/advisories/GHSA-wp76-gg32-8258 (GitHub-reviewed advisory GHSA-wp76-gg32-8258 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.63) Commands are suggestions: review each one before running it.
Loading voting…