Skip to content

← Actionable
Low, CVSS 2.7amended

Nautobot: Management of users via REST API does not apply configured password validators

CVE-2026-34203GHSA-xmpv-j7p2-j873

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nautobot 3.0.10, 2.4.30), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nautobot

    Affected
    < 2.4.30>= 3.0.0, < 3.0.10
    Fixed in
    3.0.10, 2.4.30

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-34203: 0.26% estimated exploitation activity in the next 30 days; percentile 17.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Nautobot versions prior to 2.4.30 or prior to 3.0.10, user creation and editing via the REST API fails to apply the password validation rules defined by Django's AUTHPASSWORDVALIDATORS setting (which defaults to an empty list, i.e., no specific rules, but can be configured in Nautobot's nautobotconfig.py to apply various rules if desired). This can potentially allow for the creation or modification of users to have passwords that are weak or otherwise do not comply with configured standards. Management of users via the Nautobot admin UI does correctly enforce configured password validation at this time. Patches The issue is resolved in Nautobot versions 2.4.30 and 3.0.10 and later. - https://github.com/nautobot/nautobot/pull/8778 - https://github.com/nautobot/nautobot/pull/8779 Workarounds Review which users have been granted object permissions to create and modify user accounts as well as having access tokens for the REST API, and restrict access as appropriate. It may be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xmpv-j7p2-j873

  2. Revision 1 · created ·

    Published from osv record GHSA-xmpv-j7p2-j873

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34203

Advisory: Nautobot: Management of users via REST API does not apply configured password validators
IDs: CVE-2026-34203, GHSA-xmpv-j7p2-j873
Record: https://patchnext.com/advisories/cve-2026-34203 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nautobot 3.0.10, 2.4.30. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nautobot: affected < 2.4.30; >= 3.0.0, < 3.0.10; fixed in 3.0.10, 2.4.30

## Suggested inspection (read-only)
- `python -m pip show nautobot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nautobot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xmpv-j7p2-j873 (OSV record GHSA-xmpv-j7p2-j873 lists affected ranges: PyPI nautobot >=0 =3.0.0 <3.0.10 (fixed))
- Verified: https://github.com/advisories/GHSA-xmpv-j7p2-j873 (GitHub-reviewed advisory GHSA-xmpv-j7p2-j873 lists affected ranges: PyPI nautobot >=0 =3.0.0 <3.0.10)

Commands are suggestions: review each one before running it.

Loading voting…