Skip to content

← Actionable
Critical, CVSS 9.2

Zebra node crash — V5 transaction hash panic (P2P reachable)

CVE-2026-34202GHSA-qp6f-w4r3-h8wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zebra-chain 6.0.1; zebrad 4.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io zebra-chain

    Affected
    < 6.0.1
    Fixed in
    6.0.1
  • crates.io zebrad

    Affected
    < 4.3.0
    Fixed in
    4.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
EPSS
  • CVE-2026-34202: 0.79% estimated exploitation activity in the next 30 days; percentile 56.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

--- Remote Denial of Service via Crafted V5 Transactions Summary A vulnerability in Zebra's transaction processing logic allows a remote, unauthenticated attacker to cause a Zebra node to panic (crash). This is triggered by sending a specially crafted V5 transaction that passes initial deserialization but fails during transaction ID calculation. Severity Critical - This is a Remote Denial of Service (DoS) that requires no authentication and can be triggered by a single network message. Affected Versions All Zebra versions supporting V5 transactions (Network Upgrade 5 and later) prior to version 4.3.0. Description The vulnerability stems from Zebra lazily validating transaction fields that are eagerly validated in the librustzcash parsing logic used when Zebra computes transaction ids and auth digests for V5 transactions where Zebra panics if those computations fail. PushTransaction messages with malformed V5 transactions are successfully deserialized as the zebra-chain Transaction…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qp6f-w4r3-h8wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34202

Advisory: Zebra node crash — V5 transaction hash panic (P2P reachable)
IDs: CVE-2026-34202, GHSA-qp6f-w4r3-h8wg
Record: https://patchnext.com/advisories/cve-2026-34202 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zebra-chain 6.0.1; zebrad 4.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io zebra-chain: affected < 6.0.1; fixed in 6.0.1
- crates.io zebrad: affected < 4.3.0; fixed in 4.3.0

## Suggested inspection (read-only)
- crates.io zebra-chain: check the installed version with your package manager.
- crates.io zebrad: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zebra-chain, zebrad.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qp6f-w4r3-h8wg (GitHub-reviewed advisory GHSA-qp6f-w4r3-h8wg lists affected ranges: crates.io zebrad >=0 =0 <6.0.1)

Commands are suggestions: review each one before running it.

Loading voting…