Skip to content

← Actionable
Low, CVSS 3.7amended

LiquidJS Has Memory Limit Bypass via Quadratic Amplification in replace Filter

CVE-2026-34166GHSA-mmg9-6m6j-jqqx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (liquidjs 10.25.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm liquidjs

    Affected
    <= 10.25.2
    Fixed in
    10.25.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-34166: 0.50% estimated exploitation activity in the next 30 days; percentile 42.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The replace filter in LiquidJS incorrectly accounts for memory usage when the memoryLimit option is enabled. It charges str.length + pattern.length + replacement.length bytes to the memory limiter, but the actual output from str.split(pattern).join(replacement) can be quadratically larger when the pattern occurs many times in the input string. This allows an attacker who controls template content to bypass the memoryLimit DoS protection with approximately 2,500x amplification, potentially causing out-of-memory conditions. Details The vulnerable code is in src/filters/string.ts:137-142: The memoryLimit.use() call charges only the sum of the three input lengths. However, the str.split(pattern).join(replacement) operation produces output of size: When every character in str matches pattern (e.g., str = 5,000 as, pattern = a), there are 5,000 occurrences. With a 5,000-character replacement string, the output is 5000 5000 = 25,000,000 characters, while only 5000 + 1 + 5000 =…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mmg9-6m6j-jqqx

  2. Revision 1 · created ·

    Published from osv record GHSA-mmg9-6m6j-jqqx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34166

Advisory: LiquidJS Has Memory Limit Bypass via Quadratic Amplification in `replace` Filter
IDs: CVE-2026-34166, GHSA-mmg9-6m6j-jqqx
Record: https://patchnext.com/advisories/cve-2026-34166 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: liquidjs 10.25.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm liquidjs: affected <= 10.25.2; fixed in 10.25.3

## Suggested inspection (read-only)
- `npm ls liquidjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on liquidjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mmg9-6m6j-jqqx (OSV record GHSA-mmg9-6m6j-jqqx lists affected ranges: npm liquidjs >=0 <10.25.3 (fixed))
- Verified: https://github.com/advisories/GHSA-mmg9-6m6j-jqqx (GitHub-reviewed advisory GHSA-mmg9-6m6j-jqqx lists affected ranges: npm liquidjs >=0 <=10.25.2)

Commands are suggestions: review each one before running it.

Loading voting…