PhpSpreadsheet has SSRF/RCE in IOFactory::load when $filename is user controlled
CVE-2026-34084GHSA-q4q6-r8wh-5cgh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.6.0, 3.10.4, 2.4.4, 2.1.15, 1.30.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpoffice/phpspreadsheet
- Affected
- >= 4.0.0, <= 5.5.0>= 3.3.0, <= 3.10.3>= 2.2.0, <= 2.4.3>= 2.0.0, <= 2.1.14<= 1.30.2
- Fixed in
- 3.10.4, 5.6.0, 1.30.3, 2.1.15, 2.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4q6-r8wh-5cgh lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-34084: 0.71% estimated exploitation activity in the next 30 days; percentile 53.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The usage of isfile, used to verify if the $filename is indeed an actual file, by all(?) Reader implementations (inside the helper function File::assertFile) is php-wrapper aware, for any php wrappers implementing stat(). The 3 wrappers ftp://, phar:// and ssh2.sftp://, all satisfy this requirement - 2 of which are shown in the PoC below. This results in a SSRF, at "best", and RCE at worse. This was tested against the latest release - but the issue seems to go back a while from a first quick check (still present in v1.30.2). PoC To reproduce the vulnerable behavior, the following scripts were used: php.ini file, only needed to build the malicious phar, not necessary to exploit on a deployed instance of the library: makephar.php to create the malicious file: test.php showcases the unsafe pattern: RCE Run the PoC (for RCE): The file /tmp/poc.txt should now be present on disk. Note: the vuln still triggers if the file pointed to inside the phar does not exist/is not supported (html,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q4q6-r8wh-5cgh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34084 Advisory: PhpSpreadsheet has SSRF/RCE in IOFactory::load when $filename is user controlled IDs: CVE-2026-34084, GHSA-q4q6-r8wh-5cgh Record: https://patchnext.com/advisories/cve-2026-34084 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.6.0, 3.10.4, 2.4.4, 2.1.15, 1.30.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpoffice/phpspreadsheet: affected >= 4.0.0, <= 5.5.0; >= 3.3.0, <= 3.10.3; >= 2.2.0, <= 2.4.3; >= 2.0.0, <= 2.1.14; <= 1.30.2; fixed in 3.10.4, 5.6.0, 1.30.3, 2.1.15, 2.4.4 ## Suggested inspection (read-only) - Packagist phpoffice/phpspreadsheet: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpoffice/phpspreadsheet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q4q6-r8wh-5cgh (GitHub-reviewed advisory GHSA-q4q6-r8wh-5cgh lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.2) Commands are suggestions: review each one before running it.
Loading voting…