React Router vulnerable to Denial of Service via reflected user input in single-fetch
CVE-2026-34077GHSA-rxv8-25v2-qmq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 7.14.0; turbo-stream 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm react-router
- Affected
- >= 7.0.0, < 7.14.0
- Fixed in
- 7.14.0
npm turbo-stream
- Affected
- < 3.0.0
- Fixed in
- 3.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rxv8-25v2-qmq8 lists affected ranges: npm react-router >=7.0.0 =0 <3.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rxv8-25v2-qmq8 lists affected ranges: npm react-router >=7.0.0 =0 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-34077: 0.29% estimated exploitation activity in the next 30 days; percentile 22.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A DoS vulnerability exists in the React Router v7 Framework Mode, as well as Remix v2.9.0+ with Single Fetch enabled. In some scenarios the underlying serialization algorithm can become a bottleneck when encoding specific types of data into server responses. Please upgrade to React Router v7.14.0 or later. [!NOTE] This does not impact your React Router application if you are using Declarative Mode (<BrowserRouter) or Data Mode (createBrowserRouter/<RouterProvider).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rxv8-25v2-qmq8
- Revision 1 · created ·
Published from osv record GHSA-rxv8-25v2-qmq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34077 Advisory: React Router vulnerable to Denial of Service via reflected user input in single-fetch IDs: CVE-2026-34077, GHSA-rxv8-25v2-qmq8 Record: https://patchnext.com/advisories/cve-2026-34077 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: react-router 7.14.0; turbo-stream 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm react-router: affected >= 7.0.0, < 7.14.0; fixed in 7.14.0 - npm turbo-stream: affected < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls turbo-stream --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on react-router, turbo-stream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rxv8-25v2-qmq8 (OSV record GHSA-rxv8-25v2-qmq8 lists affected ranges: npm react-router >=7.0.0 =0 <3.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rxv8-25v2-qmq8 (GitHub-reviewed advisory GHSA-rxv8-25v2-qmq8 lists affected ranges: npm react-router >=7.0.0 =0 <3.0.0) Commands are suggestions: review each one before running it.
Loading voting…