Skip to content

← Actionable
High, CVSS 7.4amended

Clerk: SSRF in the opt-in clerkFrontendApiProxy feature may leak secret keys to unintended host

CVE-2026-34076GHSA-gjxx-92w9-8v8f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@clerk/fastify 3.1.5; @clerk/express 2.0.7; @clerk/backend 3.2.3; @clerk/hono 0.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-34076: 0.32% estimated exploitation activity in the next 30 days; percentile 25.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The clerkFrontendApiProxy function in @clerk/backend is vulnerable to Server-Side Request Forgery (SSRF). An unauthenticated attacker can craft a request path that causes the proxy to send the application's Clerk-Secret-Key to an attacker-controlled server. Affected packages Only applications that have opted into the frontendApiProxy feature are affected. This feature is not enabled by default. Users of @clerk/nextjs are not affected due to how the framework handles repeated / in request paths. | Package | Affected versions | Fixed version | |---|---|---| | @clerk/backend | = 3.0.0, <= 3.2.2 | 3.2.3 | | @clerk/express | = 2.0.0, <= 2.0.6 | 2.0.7 | | @clerk/hono | = 0.1.0, <= 0.1.4 | 0.1.5 | | @clerk/fastify | = 3.1.0, <= 3.1.4 | 3.1.5 | Search your codebase for the frontendApiProxy option. If none of the patterns below appear in your code, you are not affected. @clerk/express @clerk/hono @clerk/fastify @clerk/backend A quick way to check across your entire project: If there…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gjxx-92w9-8v8f

  2. Revision 1 · created ·

    Published from osv record GHSA-gjxx-92w9-8v8f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34076

Advisory: Clerk: SSRF in the opt-in clerkFrontendApiProxy feature may leak secret keys to unintended host
IDs: CVE-2026-34076, GHSA-gjxx-92w9-8v8f
Record: https://patchnext.com/advisories/cve-2026-34076 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @clerk/fastify 3.1.5; @clerk/express 2.0.7; @clerk/backend 3.2.3; @clerk/hono 0.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @clerk/fastify: affected >= 3.1.0, <= 3.1.4; fixed in 3.1.5
- npm @clerk/express: affected >= 2.0.0, <= 2.0.6; fixed in 2.0.7
- npm @clerk/backend: affected >= 3.0.0, <= 3.2.2; fixed in 3.2.3
- npm @clerk/hono: affected >= 0.1.0, <= 0.1.4; fixed in 0.1.5

## Suggested inspection (read-only)
- `npm ls @clerk/fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @clerk/express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @clerk/backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @clerk/hono --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @clerk/fastify, @clerk/express, @clerk/backend, @clerk/hono.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gjxx-92w9-8v8f (OSV record GHSA-gjxx-92w9-8v8f lists affected ranges: npm @clerk/backend >=3.0.0 =2.0.0 =0.1.0 =3.1.0 <3.1.5 (fixed))
- Verified: https://github.com/advisories/GHSA-gjxx-92w9-8v8f (GitHub-reviewed advisory GHSA-gjxx-92w9-8v8f lists affected ranges: npm @clerk/backend >=3.0.0 =2.0.0 =0.1.0 =3.1.0 <=3.1.4)

Commands are suggestions: review each one before running it.

Loading voting…