Skip to content

← Actionable
High, CVSS 7.5amended

LangChain Core has Path Traversal vulnerabilites in legacy load_prompt functions

CVE-2026-34070GHSA-qh6h-p6c9-ff54

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-core 1.2.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-34070: 1.44% estimated exploitation activity in the next 30 days; percentile 73.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Multiple functions in langchaincore.prompts.loading read files from paths embedded in deserialized config dicts without validating against directory traversal or absolute path injection. When an application passes user-influenced prompt configurations to loadprompt() or loadpromptfromconfig(), an attacker can read arbitrary files on the host filesystem, constrained only by file-extension checks (.txt for templates, .json/.yaml for examples). Note: The affected functions (loadprompt, loadpromptfromconfig, and the .save() method on prompt classes) are undocumented legacy APIs. They are superseded by the dumpd/dumps/load/loads serialization APIs in langchaincore.load, which do not perform filesystem reads and use an allowlist-based security model. As part of this fix, the legacy APIs have been formally deprecated and will be removed in 2.0.0. Affected component Package: langchain-core File: langchaincore/prompts/loading.py Affected functions: loadtemplate(), loadexamples(),…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qh6h-p6c9-ff54

  2. Revision 1 · created ·

    Published from osv record GHSA-qh6h-p6c9-ff54

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34070

Advisory: LangChain Core has Path Traversal vulnerabilites in legacy `load_prompt` functions
IDs: CVE-2026-34070, GHSA-qh6h-p6c9-ff54
Record: https://patchnext.com/advisories/cve-2026-34070 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langchain-core 1.2.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langchain-core: affected < 1.2.22; fixed in 1.2.22

## Suggested inspection (read-only)
- `python -m pip show langchain-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langchain-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qh6h-p6c9-ff54 (OSV record GHSA-qh6h-p6c9-ff54 lists affected ranges: PyPI langchain-core >=0 <1.2.22 (fixed))
- Verified: https://github.com/advisories/GHSA-qh6h-p6c9-ff54 (GitHub-reviewed advisory GHSA-qh6h-p6c9-ff54 lists affected ranges: PyPI langchain-core >=0 <1.2.22)

Commands are suggestions: review each one before running it.

Loading voting…