Skip to content

← Actionable
High, CVSS 8.8

Moby has AuthZ plugin bypass when provided oversized request bodies

CVE-2026-34040GHSA-x744-4wpc-v9h2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/moby/moby/v2 2.0.0-beta.8; github.com/moby/moby 29.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-34040: 9.27% estimated exploitation activity in the next 30 days; percentile 95.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ) under specific circumstances. The base likelihood of this being exploited is low. This is an incomplete fix for CVE-2024-41110. Impact If you don't use AuthZ plugins, you are not affected. Using a specially-crafted API request, an attacker could make the Docker daemon forward the request to an authorization plugin without the body. The authorization plugin may allow a request which it would have otherwise denied if the body had been forwarded to it. Anyone who depends on authorization plugins that introspect the request body to make access control decisions is potentially impacted. Workarounds If unable to update immediately: - Avoid using AuthZ plugins that rely on request body inspection for security decisions. - Restrict access to the Docker API to trusted parties, following the principle of least privilege. Credits - 1seal / Oleh Konko (@1seal) - Cody (c@wormhole.guru)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x744-4wpc-v9h2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34040

Advisory: Moby has AuthZ plugin bypass when provided oversized request bodies
IDs: CVE-2026-34040, GHSA-x744-4wpc-v9h2
Record: https://patchnext.com/advisories/cve-2026-34040 (revision 1, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/moby/moby/v2 2.0.0-beta.8; github.com/moby/moby 29.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/moby/moby/v2: affected < 2.0.0-beta.8; fixed in 2.0.0-beta.8
- Go github.com/moby/moby: affected < 29.3.1; fixed in 29.3.1

## Suggested inspection (read-only)
- Go github.com/moby/moby/v2: check the installed version with your package manager.
- Go github.com/moby/moby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/moby/moby/v2, github.com/moby/moby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x744-4wpc-v9h2 (GitHub-reviewed advisory GHSA-x744-4wpc-v9h2 lists affected ranges: Go github.com/moby/moby >=0 =0 <2.0.0-beta.8)

Commands are suggestions: review each one before running it.

Loading voting…