Skip to content

← Actionable
Medium, CVSS 6.3amended

Locutus Prototype Pollution due to incomplete fix for CVE-2026-25521

CVE-2026-33994GHSA-vc8f-x9pp-wf5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (locutus 3.0.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm locutus

    Affected
    >= 2.0.39, < 3.0.25
    Fixed in
    3.0.25

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2026-33994: 0.57% estimated exploitation activity in the next 30 days; percentile 47.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A prototype pollution vulnerability exists in the parsestr function of the npm package locutus. An attacker can pollute Object.prototype by overriding RegExp.prototype.test and then passing a crafted query string to parsestr, bypassing the prototype pollution guard. This vulnerability stems from an incomplete fix for CVE-2026-25521. The CVE-2026-25521 patch replaced the String.prototype.includes()-based guard with a RegExp.prototype.test()-based guard. However, RegExp.prototype.test is itself a writable prototype method that can be overridden, making the new guard bypassable in the same way as the original — trading one hijackable built-in for another. Package locutus (npm) Affected versions = 2.0.39, <= 3.0.24 Tested and confirmed vulnerable on 2.0.39 and 3.0.24 (latest). Version 2.0.38 (pre-fix) uses a different guard (String.prototype.includes) and is not affected by this specific bypass. --- Description Details The vulnerability resides in parsestr.js where the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vc8f-x9pp-wf5p

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vc8f-x9pp-wf5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33994

Advisory: Locutus Prototype Pollution due to incomplete fix for CVE-2026-25521
IDs: CVE-2026-33994, GHSA-vc8f-x9pp-wf5p
Record: https://patchnext.com/advisories/cve-2026-33994 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: locutus 3.0.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm locutus: affected >= 2.0.39, < 3.0.25; fixed in 3.0.25

## Suggested inspection (read-only)
- `npm ls locutus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on locutus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vc8f-x9pp-wf5p (OSV record GHSA-vc8f-x9pp-wf5p lists affected ranges: npm locutus >=2.0.39 <3.0.25 (fixed))
- Verified: https://github.com/advisories/GHSA-vc8f-x9pp-wf5p (GitHub-reviewed advisory GHSA-vc8f-x9pp-wf5p lists affected ranges: npm locutus >=2.0.39 <3.0.25)

Commands are suggestions: review each one before running it.

Loading voting…