Skip to content

← Actionable
High, CVSS 8.3amended

Changedetection.io Discloses Environment Variables via jq env Builtin in Include Filters

CVE-2026-33981GHSA-58r7-4wr5-hfx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.54.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-33981: 0.48% estimated exploitation activity in the next 30 days; percentile 41.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The jq: and jqraw: include filter expressions allow use of the jq env builtin, which reads all process environment variables and stores them as the watch snapshot. An authenticated user (or unauthenticated user when no password is set, the default) can leak sensitive environment variables including SALTEDPASS, PLAYWRIGHTDRIVERURL, HTTPPROXY, and any secrets passed as env vars to the container. Details Vulnerable file: changedetectionio/htmltools.py, lines 380-388 User-supplied jq filter expressions are compiled and executed without restricting dangerous jq builtins: The form validator at forms.py:670-673 only checks that the expression compiles (jq.compile(input)) — it does not block dangerous functions. The jq env builtin reads all process environment variables regardless of the input data, returning a dictionary of every env var in the server process. PoC Step 1 — Create a watch for any JSON endpoint with jqraw:env as the include filter: If no password or API key is set…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-58r7-4wr5-hfx8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-58r7-4wr5-hfx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33981

Advisory: Changedetection.io Discloses Environment Variables via jq env Builtin in Include Filters
IDs: CVE-2026-33981, GHSA-58r7-4wr5-hfx8
Record: https://patchnext.com/advisories/cve-2026-33981 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.54.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI changedetection-io: affected <= 0.54.6; fixed in 0.54.7

## Suggested inspection (read-only)
- `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on changedetection-io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-58r7-4wr5-hfx8 (OSV record GHSA-58r7-4wr5-hfx8 lists affected ranges: PyPI changedetection-io >=0 <0.54.7 (fixed))
- Verified: https://github.com/advisories/GHSA-58r7-4wr5-hfx8 (GitHub-reviewed advisory GHSA-58r7-4wr5-hfx8 lists affected ranges: PyPI changedetection-io >=0 <=0.54.6)

Commands are suggestions: review each one before running it.

Loading voting…