Skip to content

← Actionable
Critical, CVSS 9.4amended

Signal K Server: Privilege Escalation by Admin Role Injection via /enableSecurity

CVE-2026-33950GHSA-x8hc-fqv3-7gwf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (signalk-server 2.24.0-beta.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-33950: 0.43% estimated exploitation activity in the next 30 days; percentile 37.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary According to SignalK's security documentation, when a server is first initialized without security enabled, the /skServer/enableSecurity endpoint is intentionally exposed to allow the owner to set up the initial admin account. This initial open access is by design. However, the critical vulnerability is that this route is never deregistered or disabled after the initial successful setup. Even after the genuine administrator has created their account, restarted the server, and activated token security, the /skServer/enableSecurity route remains perpetually open. Furthermore, the endpoint explicitly trusts the type field provided in the request body, passing it directly into the server's security configuration without validation. Because the route remains permanently listening, any unauthenticated user can call this endpoint at any time to silently inject a new, fully privileged admin account alongside the legitimate ones. Vulnerable Root Cause File: src/serverroutes.ts (Lines…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x8hc-fqv3-7gwf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-x8hc-fqv3-7gwf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-x8hc-fqv3-7gwf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33950

Advisory: Signal K Server: Privilege Escalation by Admin Role Injection via /enableSecurity
IDs: CVE-2026-33950, GHSA-x8hc-fqv3-7gwf
Record: https://patchnext.com/advisories/cve-2026-33950 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: signalk-server 2.24.0-beta.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm signalk-server: affected < 2.24.0-beta.4; fixed in 2.24.0-beta.4

## Suggested inspection (read-only)
- `npm ls signalk-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on signalk-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x8hc-fqv3-7gwf (GitHub-reviewed advisory GHSA-x8hc-fqv3-7gwf lists affected ranges: npm signalk-server >=0 <2.24.0-beta.4)
- Verified: https://osv.dev/vulnerability/GHSA-x8hc-fqv3-7gwf (OSV record GHSA-x8hc-fqv3-7gwf lists affected ranges: npm signalk-server >=0 <2.24.0-beta.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…