Skip to content

← Actionable
High, CVSS 8.2

MCP Ruby SDK: Insufficient Session Binding Allows SSE Stream Hijacking via Session ID Replay

CVE-2026-33946GHSA-qvqr-5cv7-wh35

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp 0.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems mcp

    Affected
    <= 0.9.1
    Fixed in
    0.9.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33946: 0.47% estimated exploitation activity in the next 30 days; percentile 41.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Ruby SDK's streamablehttptransport.rb implementation contains a session hijacking vulnerability. An attacker who obtains a valid session ID can completely hijack the victim's Server-Sent Events (SSE) stream and intercept all real-time data. Details Root Cause The StreamableHTTPTransport implementation stores only one SSE stream object per session ID and lacks: - Session-to-user identity binding - Ownership validation when establishing SSE connections - Protection against multiple simultaneous connections to the same session PoC Vulnerable Code File: streamablehttptransport.rb - L336-L339: Attack Scenario Step 1: Legitimate Session Establishment Step 2: Session ID Compromise - An attacker obtains the session ID through various means (out of scope for this analysis) Step 3: Stream Hijacking Step 4: Data Interception - ALL subsequent tool responses/notifications go to the attacker - The legitimate user receives no data and has no indication of the hijacking Technical Details…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qvqr-5cv7-wh35

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33946

Advisory: MCP Ruby SDK: Insufficient Session Binding Allows SSE Stream Hijacking via Session ID Replay
IDs: CVE-2026-33946, GHSA-qvqr-5cv7-wh35
Record: https://patchnext.com/advisories/cve-2026-33946 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp 0.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems mcp: affected <= 0.9.1; fixed in 0.9.2

## Suggested inspection (read-only)
- RubyGems mcp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qvqr-5cv7-wh35 (GitHub-reviewed advisory GHSA-qvqr-5cv7-wh35 lists affected ranges: RubyGems mcp >=0 <=0.9.1)

Commands are suggestions: review each one before running it.

Loading voting…